Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1329941
| From | "Luis R. Rodriguez" <mcgrof@suse.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy |
| Date | 2016-02-09 07:30 +0100 |
| Message-ID | <r09Ye-eN-13@gated-at.bofh.it> (permalink) |
| References | (5 earlier) <qZX10-7Mz-23@gated-at.bofh.it> <qZX10-7Mz-21@gated-at.bofh.it> <qZX11-7Mz-39@gated-at.bofh.it> <qZXaG-7Ql-35@gated-at.bofh.it> <qZXkm-7Uw-13@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Mon, Feb 08, 2016 at 04:53:00PM +0000, Andrew Cooper wrote: > On 08/02/16 16:45, Borislav Petkov wrote: > > On Mon, Feb 08, 2016 at 04:38:40PM +0000, Andrew Cooper wrote: > >> Does the early loader have extable support? If so, this is fairly easy > >> to fix. If not, we have a problem. > > It doesn't and regardless, you want to have this CPUID querying as > > simple as possible. No special handling, no special prefixes as it > > should be able to run on other hypervisors too. > > > > If one can't execute a simple CPUID(0x4...) on a xen guest and get the > > results back, then for early, we will have to do what we've done until > > now and simply emulate the MSR accesses. > > > > Later code can use then xen_cpuid() and all is fine. We should still get > > rid of paravirt_enabled() though. > > > > The force emulation prefix starts with a ud2a instruction, so extable is > to prevent it breaking on non-Xen systems. However, if extable isn't > available, this point is moot. > > As an alternative check which should be doable this early on, peeking in > the head of hypercall_page should work. If Linux was booted as a PV > guest, the hypercall_page will have been constructed by the domain > builder, and won't have 0x90's in it. Most of the paravirt_enabled() checks can be replaced with a hardware_subarch check once we modify the xen_start_kernel() to add that, today XEN is unused even though it was added eons ago. Part of my work was to remove as many paravirt_enabled() checks. I'll reply to Andy's original e-mail now indicating which ones I could address, it sounds like with this nugget and some other work we might be able to address all. I should note, in the future the check for subarch would be an explicit part of the x86 early init init routines to avoid further issues but only in between x86_64_start_reservations() and setup_arch(). How *early* can such a hypercall _page check be *safely* be called? I say safely here as if we're not on Xen are we OK to muck around and check the same address space? Provided we use the subarch for PV to remove a lot of the paravirt_enabled() checks, is HVMLite still OK if it ends up using PC subarch and there not being a paravirt_enabled() anyamore? Boris O's HVMLite series added paravirt_enabled = 1 for the new HVMLite. Luis
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@kernel.org> - 2016-02-06 05:40 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-06 08:20 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-06 10:10 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-06 21:10 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-06 23:10 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 16:50 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:00 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:10 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:20 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:30 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:40 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:40 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:50 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 18:00 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 18:20 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 07:30 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 18:00 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 21:50 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 22:10 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:50 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 18:00 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:40 +0100
Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:40 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 16:40 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 16:50 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 08:10 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-08 22:10 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 08:10 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@kernel.org> - 2016-02-17 21:10 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-17 22:00 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@kernel.org> - 2016-02-17 22:20 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-17 22:30 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-17 23:10 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-17 23:20 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-17 23:50 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-18 00:40 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-17 23:30 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-17 23:40 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 07:50 +0100
Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 23:00 +0100
csiph-web