Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1329274

Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy

From Andrew Cooper <andrew.cooper3@citrix.com>
Newsgroups linux.kernel
Subject Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy
Date 2016-02-08 17:30 +0100
Message-ID <qZWRk-7IX-31@gated-at.bofh.it> (permalink)
References (5 earlier) <qZjdg-5hi-3@gated-at.bofh.it> <qZWeB-7eV-15@gated-at.bofh.it> <qZWoi-7it-7@gated-at.bofh.it> <qZWy1-7BS-71@gated-at.bofh.it> <qZWHE-7Fq-35@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 08/02/16 16:12, Boris Ostrovsky wrote:
>
>
> On 02/08/2016 11:05 AM, Andrew Cooper wrote:
>>
>> For compatibility with other virtualisation specs, Xen's cpuid leaves
>> shift depending on configuration.
>>
>> Spec at
>> http://xenbits.xen.org/gitweb/?p=xen.git;a=blob;f=xen/include/public/arch-x86/cpuid.h;h=d709340f18d089560b959835eabb7b6609542c7e;hb=HEAD#l33
>>
>>
>> Basically, they are either at 0x40000000, or 0x40000100 if viridian or
>> vmware compatibility has been enabled.
>
> (Also in arch/x86/include/asm/xen/cpuid.h in Linux tree).

The other complication is that, for a PV guest, you must use the forced
emulation prefix for the cpuid instruction to trap into the hypervisor.

This either means you must be sure you are under Xen to start with, or
use an extable entry to catch the #UD fault if you are not under Xen.

~Andrew

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@kernel.org> - 2016-02-06 05:40 +0100
  Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-06 08:20 +0100
    Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-06 10:10 +0100
      Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-06 21:10 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-06 23:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 16:50 +0100
            Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:00 +0100
              Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:10 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:20 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:30 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 18:20 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 07:30 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 21:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 22:10 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:40 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 16:40 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 16:50 +0100
            Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 08:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-08 22:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 08:10 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 07:50 +0100
      Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 23:00 +0100

csiph-web