Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1328240

Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy

From Andy Lutomirski <luto@amacapital.net>
Newsgroups linux.kernel
Subject Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy
Date 2016-02-06 08:20 +0100
Message-ID <qZ5jX-3SI-5@gated-at.bofh.it> (permalink)
References <qZ2P7-1YX-3@gated-at.bofh.it> <qZ2P7-1YX-1@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Feb 5, 2016 8:30 PM, "Luis R. Rodriguez" <mcgrof@kernel.org> wrote:
>
> paravirt_enabled conveys the idea that if this is set or if
> paravirt_enabled() returns true you are in a paravirtualized
> environment. This is not true by any means, and left as-is
> is just causing confusion and is prone to be misused and abused.
>
> This primitive is really only useful to determine if you have a
> paravirtualization hypervisor that supports legacy paravirtualized
> guests. At run time, this tells us if we've booted into a Linux guest
> with support for legacy devices and features.
>
> To avoid further issues with semantics on this we loosely borrow
> the definition of "legacy" from both the ACPI 5.2.9.3 "IA-PC Boot
> Architecture Flags" section and the PC 2001 definition in the PC
> Systems design guide [0]:
>
>   paravirt_legacy() is true if this hypervisor supports legacy
>                     x86 paravirtualized guests.

This needs to be far more concrete.  I'm reasonably well versed in x86
details relevant to kernels ans I have *no clue* what your semantics
mean.

> +/**
> + * struct pv_info - paravirt hypervisor information
> + *
> + * @supports_x86_legacy: true if this hypervisor supports legacy x86
> + *     paravirtualized guests.  The definition of legacy here adheres
> + *     *loosely* to both the notion of legacy in the ACPI 5.2.9.3 "IA-PC Boot
> + *     Architecture Flags" section and the PC 2001 "legacy free" concept [1]
> + *     referred to in the PC System Design Guide [2] [3] on Chapter 3, Page 50
> + *     [4].  Legacy x86 guests systems are guest systems which are not "legacy
> + *     free" as per the PC 2001 definition, and in the ACPI sense could have
> + *     any of the legacy ACPI IA-PC Boot architecture flags set. These are x86
> + *     systems with any type of legacy peripherals or requirements.
> + *
> + *     Examples of some popular legacy peripherals:
> + *
> + *       a) Floppy drive
> + *       b) Legacy ports [1] such as such as parallel ports, PS/2 connectors,
> + *          serial ports / RS-232, game ports Parallel ATA, and IEEE 1394
> + *       c) ISA bus
> + *
> + *     Examples of features required to support such type of legacy guests
> + *     are the need for APM and a PNP BIOS.

Seriously?  I think you just defined every standard native x86 system
as well as QEMU/KVM as "legacy".

Can we just enumerate this crap?  I propose:

Xen PV and lguest are paravirt_legacy.  Nothing else is
paravirt_legacy.  The addition of new paravirt_legacy support is
strongly discouraged.

--Andy

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@kernel.org> - 2016-02-06 05:40 +0100
  Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-06 08:20 +0100
    Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-06 10:10 +0100
      Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-06 21:10 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-06 23:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 16:50 +0100
            Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:00 +0100
              Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:10 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:20 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:30 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 18:20 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 07:30 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 21:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 22:10 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:40 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 16:40 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 16:50 +0100
            Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 08:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-08 22:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 08:10 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 07:50 +0100
      Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 23:00 +0100

csiph-web