Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1329223

Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy

From Borislav Petkov <bp@alien8.de>
Newsgroups linux.kernel
Subject Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy
Date 2016-02-08 17:00 +0100
Message-ID <qZWoi-7it-7@gated-at.bofh.it> (permalink)
References (2 earlier) <qZ5jX-3SI-5@gated-at.bofh.it> <qZ72p-55L-9@gated-at.bofh.it> <qZhl8-3QS-13@gated-at.bofh.it> <qZjdg-5hi-3@gated-at.bofh.it> <qZWeB-7eV-15@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, Feb 08, 2016 at 10:39:43AM -0500, Boris Ostrovsky wrote:
> It does. Very much IIRC, the problem was not caused by an access to MSR but
> rather some sort of address not being available somewhere.

See below.

> >- microcode application on Xen: we've had this before. The hypervisor
> >should do that (if it doesn't do so already).
> 
> it does.

Good.

> >So yes, that paravirt_enabled() thing should go away. Even more so if we
> >have CPUID leaf 0x4... reserved for hypervisors.
> 
> I actually think this was the original proposal until we realized we had
> paravirt_enabled(). So we can go back to checking CPUID 0x40000000.
> 
> We might also be able to test for (x86_hyper!=NULL) and have guests that do
> microcode management prior to init_hypervisor() rely on hypervisors ignoring
> MSR accesses (as they do today).

Right, so the early loader can't do that as on 32-bit it runs even
before paging has been enabled. So I *think* the thing with CPUID would
be best. What does the xen hypervisor return in regs when I do CPUID(4)?
I.e., how do I reliably detect it in the guest?

I can whip up a quick patch and get rid of paravirt_enabled() while at
it...

-- 
Regards/Gruss,
    Boris.

ECO tip #101: Trim your mails when you reply.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@kernel.org> - 2016-02-06 05:40 +0100
  Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-06 08:20 +0100
    Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-06 10:10 +0100
      Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-06 21:10 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-06 23:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 16:50 +0100
            Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:00 +0100
              Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:10 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:20 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:30 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 18:20 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 07:30 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 21:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 22:10 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:40 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 16:40 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 16:50 +0100
            Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 08:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-08 22:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 08:10 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 07:50 +0100
      Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 23:00 +0100

csiph-web