Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1329945

Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy

From "Luis R. Rodriguez" <mcgrof@suse.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy
Date 2016-02-09 08:10 +0100
Message-ID <r0aAV-JQ-1@gated-at.bofh.it> (permalink)
References (2 earlier) <qZ5jX-3SI-5@gated-at.bofh.it> <qZ72p-55L-9@gated-at.bofh.it> <qZhl8-3QS-13@gated-at.bofh.it> <qZW4X-7bA-23@gated-at.bofh.it> <qZWeC-7eV-31@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Mon, Feb 08, 2016 at 04:46:08PM +0100, Borislav Petkov wrote:
> On Mon, Feb 08, 2016 at 10:31:36AM -0500, Boris Ostrovsky wrote:
> > This range is reserved for hypervisors but the only hypervisor that uses it
> > is Xen PV (lguest doesn't run in 64-bit mode).
> 
> Yeah, this is mentioned in arch/x86/include/asm/page_64_types.h:
> 
> /*
>  * Set __PAGE_OFFSET to the most negative possible address +
>  * PGDIR_SIZE*16 (pgd slot 272).  The gap is to allow a space for a
>  * hypervisor to fit.  Choosing 16 slots here is arbitrary, but it's
>  * what Xen requires.
>  */
> #define __PAGE_OFFSET           _AC(0xffff880000000000, UL)
> 
> It is also in Documentation/x86/x86_64/mm.txt:
> 
> ffff800000000000 - ffff87ffffffffff (=43 bits) guard hole, reserved for hypervisor
> 
> albeit a bit laconic.

It doesn't sound like we have a replacement strategy for this yet?
If not, for PV we can rely on the subarch, but only once its set,
I can take this on as part of my work if agreeable given I'm adding
the use of the Xen subarch. If we want this in before linker table
stuff gets fleshed out this I can just split out setting the subarch
on xen_start_kernel() and replacing paravirt_enabled() where
applicable. But -- what about HVMLite for this, given as-is currently
HVMLite is to use PC subarch?

  Luis

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@kernel.org> - 2016-02-06 05:40 +0100
  Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-06 08:20 +0100
    Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-06 10:10 +0100
      Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-06 21:10 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-06 23:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 16:50 +0100
            Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:00 +0100
              Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:10 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:20 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:30 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 17:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 18:20 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 07:30 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 21:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 22:10 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:50 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 18:00 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Andrew Cooper <andrew.cooper3@citrix.com> - 2016-02-08 17:40 +0100
                Re: [Xen-devel] [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 17:40 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 16:40 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-08 16:50 +0100
            Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 08:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-08 22:10 +0100
          Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 08:10 +0100
            Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@kernel.org> - 2016-02-17 21:10 +0100
              Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-17 22:00 +0100
                Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy "Luis R. Rodriguez" <mcgrof@kernel.org> - 2016-02-17 22:20 +0100
                Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-17 22:30 +0100
                Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-17 23:10 +0100
                Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to paravirt_legacy Andy Lutomirski <luto@amacapital.net> - 2016-02-17 23:20 +0100
                Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-17 23:50 +0100
                Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Borislav Petkov <bp@alien8.de> - 2016-02-18 00:40 +0100
                Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-17 23:30 +0100
                Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-17 23:40 +0100
        Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy "Luis R. Rodriguez" <mcgrof@suse.com> - 2016-02-09 07:50 +0100
      Re: [PATCH v2 3/3] paravirt: rename paravirt_enabled to  paravirt_legacy Boris Ostrovsky <boris.ostrovsky@oracle.com> - 2016-02-08 23:00 +0100

csiph-web