Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1515893
| From | Michael Ellerman <mpe@ellerman.id.au> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso |
| Date | 2016-11-07 09:10 +0100 |
| Message-ID | <sANaa-gv-7@gated-at.bofh.it> (permalink) |
| References | <syKT7-36U-1@gated-at.bofh.it> <syKT8-36U-13@gated-at.bofh.it> <szTrk-6zi-37@gated-at.bofh.it> <szTrk-6zi-35@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Will Deacon <will.deacon@arm.com> writes: > On Fri, Nov 04, 2016 at 03:58:22PM +1100, Michael Ellerman wrote: >> Christopher Covington <cov@codeaurora.org> writes: >> > arch/powerpc/include/asm/book3s/32/mmu-hash.h | 2 +- >> > arch/powerpc/include/asm/book3s/64/mmu.h | 2 +- >> > arch/powerpc/include/asm/mm-arch-hooks.h | 6 +++--- >> > arch/powerpc/include/asm/mmu-40x.h | 2 +- >> > arch/powerpc/include/asm/mmu-44x.h | 2 +- >> > arch/powerpc/include/asm/mmu-8xx.h | 2 +- >> > arch/powerpc/include/asm/mmu-book3e.h | 2 +- >> > arch/powerpc/include/asm/mmu_context.h | 4 ++-- >> > arch/powerpc/include/asm/vdso.h | 2 +- >> > arch/powerpc/include/uapi/asm/elf.h | 2 +- >> > arch/powerpc/kernel/signal_32.c | 8 ++++---- >> > arch/powerpc/kernel/signal_64.c | 4 ++-- >> > arch/powerpc/kernel/vdso.c | 8 ++++---- >> > arch/powerpc/perf/callchain.c | 12 ++++++------ >> > 14 files changed, 29 insertions(+), 29 deletions(-) >> >> This is kind of annoying, but I guess it's worth doing. >> >> It's going to conflict like hell though. Who were you thinking would >> merge this series? I think it should go via Andrew Morton's tree, as >> that way if we get bad conflicts we can pull it out and redo it. > > The other thing you can do is generate the patch towards the end of the > merge window and send it as a separate pull request. The disadvantage of > that is that it can't spend any time in -next, but that might be ok for a > mechanical rename. True. Though in this case it's a mechanical rename that then allows us to use the generic code, so I'd prefer we had some -next coverage on the latter. The other other option would be to wrap all uses of the arch value in a macro (or actually two probably, one a getter one a setter). That would then allow arches to use the generic code regardless of the name and type of their mm->context.vdso_whatever. That would allow the basic series to go in, and then each arch could do a series later that switches it to the "standard" name and type. cheers
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
[RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
Re: [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Will Deacon <will.deacon@arm.com> - 2016-11-04 21:40 +0100
Re: [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Michael Ellerman <mpe@ellerman.id.au> - 2016-11-07 09:10 +0100
[RFC v2 4/7] arm64: Use generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
[RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Michael Ellerman <mpe@ellerman.id.au> - 2016-11-04 06:00 +0100
Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Laurent Dufour <ldufour@linux.vnet.ibm.com> - 2016-11-07 21:30 +0100
Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Michael Ellerman <mpe@ellerman.id.au> - 2016-11-08 01:00 +0100
[RFC v2 3/7] arm64: Use unsigned long for VDSO Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
[RFC v2 2/7] arm: Use generic VDSO unmap and remap Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
Re: [RFC v2 2/7] arm: Use generic VDSO unmap and remap Russell King - ARM Linux <linux@armlinux.org.uk> - 2016-11-01 18:30 +0100
Re: [RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Dmitry Safonov <0x7f454c46@gmail.com> - 2016-11-01 18:30 +0100
Re: [RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-02 01:30 +0100
csiph-web