Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1514996

Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions

From Michael Ellerman <mpe@ellerman.id.au>
Newsgroups linux.kernel
Subject Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions
Date 2016-11-04 06:00 +0100
Message-ID <szELD-5il-9@gated-at.bofh.it> (permalink)
References <syKT7-36U-1@gated-at.bofh.it> <syKT8-36U-17@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Christopher Covington <cov@codeaurora.org> writes:

> The PowerPC VDSO remap and unmap code was copied to a generic location,
> only modifying the variable name expected in mm->context (vdso instead of
> vdso_base) to match most other architectures. Having adopted this generic
> naming, drop the code in arch/powerpc and use the generic version.
>
> Signed-off-by: Christopher Covington <cov@codeaurora.org>
> ---
>  arch/powerpc/Kconfig                     |  1 +
>  arch/powerpc/include/asm/Kbuild          |  1 +
>  arch/powerpc/include/asm/mm-arch-hooks.h | 28 -------------------------
>  arch/powerpc/include/asm/mmu_context.h   | 35 +-------------------------------
>  4 files changed, 3 insertions(+), 62 deletions(-)
>  delete mode 100644 arch/powerpc/include/asm/mm-arch-hooks.h

This looks OK.

Have you tested it on powerpc? I could but I don't know how to actually
trigger these paths, I assume I need a CRIU setup?

Can you flip the subject to "powerpc/mm: ...".

cheers

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
  [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
    Re: [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Will Deacon <will.deacon@arm.com> - 2016-11-04 21:40 +0100
      Re: [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Michael Ellerman <mpe@ellerman.id.au> - 2016-11-07 09:10 +0100
  [RFC v2 4/7] arm64: Use generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
  [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
    Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Michael Ellerman <mpe@ellerman.id.au> - 2016-11-04 06:00 +0100
      Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap  functions Laurent Dufour <ldufour@linux.vnet.ibm.com> - 2016-11-07 21:30 +0100
        Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Michael Ellerman <mpe@ellerman.id.au> - 2016-11-08 01:00 +0100
  [RFC v2 3/7] arm64: Use unsigned long for VDSO Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
  [RFC v2 2/7] arm: Use generic VDSO unmap and remap Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
    Re: [RFC v2 2/7] arm: Use generic VDSO unmap and remap Russell King - ARM Linux <linux@armlinux.org.uk> - 2016-11-01 18:30 +0100
  Re: [RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Dmitry Safonov <0x7f454c46@gmail.com> - 2016-11-01 18:30 +0100
    Re: [RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-02 01:30 +0100

csiph-web