Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1513385

[RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions

From Christopher Covington <cov@codeaurora.org>
Newsgroups linux.kernel
Subject [RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions
Date 2016-11-01 18:20 +0100
Message-ID <syKT7-36U-1@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


When Address Space Layout Randomization (ASLR, randmaps) is enabled, the
address of the VDSO fluctuates from one process to the next. If
Checkpoint/Restore In Userspace (CRIU) is to fully replicate the memory map
of a previous process, it must be able to remap the VDSO of a new process
to the address used by the previous process. Historically this has been
implemented in architecture-specific code for PowerPC and x86. In order to
support 32-bit and 64-bit ARM without further duplication of code, copy
Laurent Dufour's implementation for PowerPC with slight modifications to a
generic location. This is hopefully the beginning of a long process of VDSO
code de-duplication between architectures.

Signed-off-by: Christopher Covington <cov@codeaurora.org>
---
 include/asm-generic/mm_hooks.h | 35 ++++++++++++++++++++++++++++++++---
 1 file changed, 32 insertions(+), 3 deletions(-)

diff --git a/include/asm-generic/mm_hooks.h b/include/asm-generic/mm_hooks.h
index cc5d9a1..73f09f1 100644
--- a/include/asm-generic/mm_hooks.h
+++ b/include/asm-generic/mm_hooks.h
@@ -1,7 +1,17 @@
 /*
- * Define generic no-op hooks for arch_dup_mmap, arch_exit_mmap
- * and arch_unmap to be included in asm-FOO/mmu_context.h for any
- * arch FOO which doesn't need to hook these.
+ * Define generic hooks for arch_dup_mmap, arch_exit_mmap and arch_unmap to be
+ * included in asm-FOO/mmu_context.h for any arch FOO which doesn't need to
+ * specially hook these.
+ *
+ * arch_remap originally from include/linux-mm-arch-hooks.h
+ * arch_unmap originally from arch/powerpc/include/asm/mmu_context.h
+ * Copyright (C) 2015, IBM Corporation
+ * Author: Laurent Dufour <ldufour@linux.vnet.ibm.com>
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ *
  */
 #ifndef _ASM_GENERIC_MM_HOOKS_H
 #define _ASM_GENERIC_MM_HOOKS_H
@@ -19,6 +29,25 @@ static inline void arch_unmap(struct mm_struct *mm,
 			struct vm_area_struct *vma,
 			unsigned long start, unsigned long end)
 {
+#ifdef CONFIG_GENERIC_VDSO
+	if (start <= mm->context.vdso && mm->context.vdso < end)
+		mm->context.vdso = 0;
+#endif /* CONFIG_GENERIC_VDSO */
+}
+
+static inline void arch_remap(struct mm_struct *mm,
+			      unsigned long old_start, unsigned long old_end,
+			      unsigned long new_start, unsigned long new_end)
+{
+#ifdef CONFIG_GENERIC_VDSO
+	/*
+	 * mremap() doesn't allow moving multiple vmas so we can limit the
+	 * check to old_addr == vdso.
+	 */
+	if (old_addr == mm->context.vdso)
+		mm->context.vdso = new_addr;
+
+#endif /* CONFIG_GENERIC_VDSO */
 }
 
 static inline void arch_bprm_mm_init(struct mm_struct *mm,
-- 
Qualcomm Datacenter Technologies as an affiliate of Qualcomm Technologies, Inc.
Qualcomm Technologies, Inc. is a member of the
Code Aurora Forum, a Linux Foundation Collaborative Project.

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
  [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
    Re: [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Will Deacon <will.deacon@arm.com> - 2016-11-04 21:40 +0100
      Re: [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Michael Ellerman <mpe@ellerman.id.au> - 2016-11-07 09:10 +0100
  [RFC v2 4/7] arm64: Use generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
  [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
    Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Michael Ellerman <mpe@ellerman.id.au> - 2016-11-04 06:00 +0100
      Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap  functions Laurent Dufour <ldufour@linux.vnet.ibm.com> - 2016-11-07 21:30 +0100
        Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Michael Ellerman <mpe@ellerman.id.au> - 2016-11-08 01:00 +0100
  [RFC v2 3/7] arm64: Use unsigned long for VDSO Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
  [RFC v2 2/7] arm: Use generic VDSO unmap and remap Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
    Re: [RFC v2 2/7] arm: Use generic VDSO unmap and remap Russell King - ARM Linux <linux@armlinux.org.uk> - 2016-11-01 18:30 +0100
  Re: [RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Dmitry Safonov <0x7f454c46@gmail.com> - 2016-11-01 18:30 +0100
    Re: [RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-02 01:30 +0100

csiph-web