Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1513394
| From | Russell King - ARM Linux <linux@armlinux.org.uk> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [RFC v2 2/7] arm: Use generic VDSO unmap and remap |
| Date | 2016-11-01 18:30 +0100 |
| Message-ID | <syL2N-3ae-9@gated-at.bofh.it> (permalink) |
| References | <syKT7-36U-1@gated-at.bofh.it> <syKT8-36U-21@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
You know, on its own, this patch is totally meaningless. Sorry, there's nothing more I can say about this. On Tue, Nov 01, 2016 at 11:10:56AM -0600, Christopher Covington wrote: > Checkpoint/Restore In Userspace (CRIU) needs to be able to unmap and remap > the VDSO to successfully checkpoint and restore applications in the face of > changing VDSO addresses due to Address Space Layout Randomization (ASLR, > randmaps). Previously, this was implemented in architecture-specific code > for PowerPC and x86. However, a generic version based on Laurent Dufour's > PowerPC implementation is now available, so begin using it on ARM. > > Signed-off-by: Christopher Covington <cov@codeaurora.org> > --- > arch/arm/mm/Kconfig | 1 + > 1 file changed, 1 insertion(+) > > diff --git a/arch/arm/mm/Kconfig b/arch/arm/mm/Kconfig > index c1799dd..1d3312b 100644 > --- a/arch/arm/mm/Kconfig > +++ b/arch/arm/mm/Kconfig > @@ -845,6 +845,7 @@ config VDSO > depends on AEABI && MMU && CPU_V7 > default y if ARM_ARCH_TIMER > select GENERIC_TIME_VSYSCALL > + select GENERIC_VDSO > help > Place in the process address space an ELF shared object > providing fast implementations of gettimeofday and > -- > Qualcomm Datacenter Technologies as an affiliate of Qualcomm Technologies, Inc. > Qualcomm Technologies, Inc. is a member of the > Code Aurora Forum, a Linux Foundation Collaborative Project. > -- RMK's Patch system: http://www.armlinux.org.uk/developer/patches/ FTTC broadband for 0.8mile line: currently at 9.6Mbps down 400kbps up according to speedtest.net.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
[RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
Re: [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Will Deacon <will.deacon@arm.com> - 2016-11-04 21:40 +0100
Re: [RFC v2 5/7] powerpc: Rename context.vdso_base to context.vdso Michael Ellerman <mpe@ellerman.id.au> - 2016-11-07 09:10 +0100
[RFC v2 4/7] arm64: Use generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
[RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Michael Ellerman <mpe@ellerman.id.au> - 2016-11-04 06:00 +0100
Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Laurent Dufour <ldufour@linux.vnet.ibm.com> - 2016-11-07 21:30 +0100
Re: [RFC v2 6/7] mm/powerpc: Use generic VDSO remap and unmap functions Michael Ellerman <mpe@ellerman.id.au> - 2016-11-08 01:00 +0100
[RFC v2 3/7] arm64: Use unsigned long for VDSO Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
[RFC v2 2/7] arm: Use generic VDSO unmap and remap Christopher Covington <cov@codeaurora.org> - 2016-11-01 18:20 +0100
Re: [RFC v2 2/7] arm: Use generic VDSO unmap and remap Russell King - ARM Linux <linux@armlinux.org.uk> - 2016-11-01 18:30 +0100
Re: [RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Dmitry Safonov <0x7f454c46@gmail.com> - 2016-11-01 18:30 +0100
Re: [RFC v2 1/7] mm: Provide generic VDSO unmap and remap functions Christopher Covington <cov@codeaurora.org> - 2016-11-02 01:30 +0100
csiph-web