Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1413181
| From | Jonathan Cameron <jic23@kernel.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 2/8] iio: adc: ti_am335x_adc: use SIMPLE_DEV_PM_OPS helper macro |
| Date | 2016-06-03 14:20 +0200 |
| Message-ID | <rFWf1-32g-39@gated-at.bofh.it> (permalink) |
| References | <rEVkZ-5uA-3@gated-at.bofh.it> <rEVl1-5uA-55@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 31/05/16 18:00, Andrew F. Davis wrote:
> Replace ifdefs with SIMPLE_DEV_PM_OPS helper macro.
>
> Signed-off-by: Andrew F. Davis <afd@ti.com>
Applied to the togreg branch of iio.git - initially pushed out as testing
for the autobuilders to play with it.
Thanks,
Jonathan
> ---
> drivers/iio/adc/ti_am335x_adc.c | 16 ++++------------
> 1 file changed, 4 insertions(+), 12 deletions(-)
>
> diff --git a/drivers/iio/adc/ti_am335x_adc.c b/drivers/iio/adc/ti_am335x_adc.c
> index c1e0553..18af71d 100644
> --- a/drivers/iio/adc/ti_am335x_adc.c
> +++ b/drivers/iio/adc/ti_am335x_adc.c
> @@ -531,8 +531,7 @@ static int tiadc_remove(struct platform_device *pdev)
> return 0;
> }
>
> -#ifdef CONFIG_PM
> -static int tiadc_suspend(struct device *dev)
> +static int __maybe_unused tiadc_suspend(struct device *dev)
> {
> struct iio_dev *indio_dev = dev_get_drvdata(dev);
> struct tiadc_device *adc_dev = iio_priv(indio_dev);
> @@ -550,7 +549,7 @@ static int tiadc_suspend(struct device *dev)
> return 0;
> }
>
> -static int tiadc_resume(struct device *dev)
> +static int __maybe_unused tiadc_resume(struct device *dev)
> {
> struct iio_dev *indio_dev = dev_get_drvdata(dev);
> struct tiadc_device *adc_dev = iio_priv(indio_dev);
> @@ -567,14 +566,7 @@ static int tiadc_resume(struct device *dev)
> return 0;
> }
>
> -static const struct dev_pm_ops tiadc_pm_ops = {
> - .suspend = tiadc_suspend,
> - .resume = tiadc_resume,
> -};
> -#define TIADC_PM_OPS (&tiadc_pm_ops)
> -#else
> -#define TIADC_PM_OPS NULL
> -#endif
> +static SIMPLE_DEV_PM_OPS(tiadc_pm_ops, tiadc_suspend, tiadc_resume);
>
> static const struct of_device_id ti_adc_dt_ids[] = {
> { .compatible = "ti,am3359-adc", },
> @@ -585,7 +577,7 @@ MODULE_DEVICE_TABLE(of, ti_adc_dt_ids);
> static struct platform_driver tiadc_driver = {
> .driver = {
> .name = "TI-am335x-adc",
> - .pm = TIADC_PM_OPS,
> + .pm = &tiadc_pm_ops,
> .of_match_table = ti_adc_dt_ids,
> },
> .probe = tiadc_probe,
>
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/8] TI AM335x TSC/ADC cleanup "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
[PATCH 3/8] mfd: ti_am335x_tscadc: Remove use of single line functions "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 3/8] mfd: ti_am335x_tscadc: Remove use of single line functions Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 5/8] mfd: ti_am335x_tscadc: Rename regmap_tscadc to regmap "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 5/8] mfd: ti_am335x_tscadc: Rename regmap_tscadc to regmap Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 7/8] iio: adc: ti_am335x_adc: use variable names for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 7/8] iio: adc: ti_am335x_adc: use variable names for sizeof() operator Jonathan Cameron <jic23@kernel.org> - 2016-06-03 14:20 +0200
[PATCH 8/8] Input: ti_am335x_tsc - use variable name for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 8/8] Input: ti_am335x_tsc - use variable name for sizeof() operator Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2016-06-01 20:40 +0200
[PATCH 6/8] mfd: ti_am335x_tscadc: use variable name for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
[PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev Dave Gerlach <d-gerlach@ti.com> - 2016-05-31 20:00 +0200
Re: [PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 2/8] iio: adc: ti_am335x_adc: use SIMPLE_DEV_PM_OPS helper macro "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 2/8] iio: adc: ti_am335x_adc: use SIMPLE_DEV_PM_OPS helper macro Jonathan Cameron <jic23@kernel.org> - 2016-06-03 14:20 +0200
Re: [PATCH 0/8] TI AM335x TSC/ADC cleanup Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
csiph-web