Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1411459
| From | Dmitry Torokhov <dmitry.torokhov@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 8/8] Input: ti_am335x_tsc - use variable name for sizeof() operator |
| Date | 2016-06-01 20:40 +0200 |
| Message-ID | <rFjdE-3CV-1@gated-at.bofh.it> (permalink) |
| References | <rEVkZ-5uA-3@gated-at.bofh.it> <rEVl0-5uA-23@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tue, May 31, 2016 at 12:00:13PM -0500, Andrew F. Davis wrote:
> Fix the code formatting to use the kernel preferred style
> of using the actual variables to determize the size using
> the sizeof() operator.
>
> Signed-off-by: Andrew F. Davis <afd@ti.com>
Applied, thank you.
> ---
> drivers/input/touchscreen/ti_am335x_tsc.c | 2 +-
> 1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/input/touchscreen/ti_am335x_tsc.c b/drivers/input/touchscreen/ti_am335x_tsc.c
> index 8b3f15c..7953381 100644
> --- a/drivers/input/touchscreen/ti_am335x_tsc.c
> +++ b/drivers/input/touchscreen/ti_am335x_tsc.c
> @@ -406,7 +406,7 @@ static int titsc_probe(struct platform_device *pdev)
> int err;
>
> /* Allocate memory for device */
> - ts_dev = kzalloc(sizeof(struct titsc), GFP_KERNEL);
> + ts_dev = kzalloc(sizeof(*ts_dev), GFP_KERNEL);
> input_dev = input_allocate_device();
> if (!ts_dev || !input_dev) {
> dev_err(&pdev->dev, "failed to allocate memory.\n");
> --
> 2.8.3
>
--
Dmitry
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/8] TI AM335x TSC/ADC cleanup "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
[PATCH 3/8] mfd: ti_am335x_tscadc: Remove use of single line functions "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 3/8] mfd: ti_am335x_tscadc: Remove use of single line functions Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 5/8] mfd: ti_am335x_tscadc: Rename regmap_tscadc to regmap "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 5/8] mfd: ti_am335x_tscadc: Rename regmap_tscadc to regmap Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 7/8] iio: adc: ti_am335x_adc: use variable names for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 7/8] iio: adc: ti_am335x_adc: use variable names for sizeof() operator Jonathan Cameron <jic23@kernel.org> - 2016-06-03 14:20 +0200
[PATCH 8/8] Input: ti_am335x_tsc - use variable name for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 8/8] Input: ti_am335x_tsc - use variable name for sizeof() operator Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2016-06-01 20:40 +0200
[PATCH 6/8] mfd: ti_am335x_tscadc: use variable name for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
[PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev Dave Gerlach <d-gerlach@ti.com> - 2016-05-31 20:00 +0200
Re: [PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 2/8] iio: adc: ti_am335x_adc: use SIMPLE_DEV_PM_OPS helper macro "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 2/8] iio: adc: ti_am335x_adc: use SIMPLE_DEV_PM_OPS helper macro Jonathan Cameron <jic23@kernel.org> - 2016-06-03 14:20 +0200
Re: [PATCH 0/8] TI AM335x TSC/ADC cleanup Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
csiph-web