Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1410438
| From | "Andrew F. Davis" <afd@ti.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 7/8] iio: adc: ti_am335x_adc: use variable names for sizeof() operator |
| Date | 2016-05-31 19:10 +0200 |
| Message-ID | <rEVl0-5uA-21@gated-at.bofh.it> (permalink) |
| References | <rEVkZ-5uA-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Fix the code formatting to use the kernel preferred style
of using the actual variables to determize the size using
the sizeof() operator.
Signed-off-by: Andrew F. Davis <afd@ti.com>
---
drivers/iio/adc/ti_am335x_adc.c | 6 ++----
1 file changed, 2 insertions(+), 4 deletions(-)
diff --git a/drivers/iio/adc/ti_am335x_adc.c b/drivers/iio/adc/ti_am335x_adc.c
index 18af71d..8a36875 100644
--- a/drivers/iio/adc/ti_am335x_adc.c
+++ b/drivers/iio/adc/ti_am335x_adc.c
@@ -326,8 +326,7 @@ static int tiadc_channel_init(struct iio_dev *indio_dev, int channels)
int i;
indio_dev->num_channels = channels;
- chan_array = kcalloc(channels,
- sizeof(struct iio_chan_spec), GFP_KERNEL);
+ chan_array = kcalloc(channels, sizeof(*chan_array), GFP_KERNEL);
if (chan_array == NULL)
return -ENOMEM;
@@ -467,8 +466,7 @@ static int tiadc_probe(struct platform_device *pdev)
return -EINVAL;
}
- indio_dev = devm_iio_device_alloc(&pdev->dev,
- sizeof(struct tiadc_device));
+ indio_dev = devm_iio_device_alloc(&pdev->dev, sizeof(*indio_dev));
if (indio_dev == NULL) {
dev_err(&pdev->dev, "failed to allocate iio device\n");
return -ENOMEM;
--
2.8.3
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/8] TI AM335x TSC/ADC cleanup "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
[PATCH 3/8] mfd: ti_am335x_tscadc: Remove use of single line functions "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 3/8] mfd: ti_am335x_tscadc: Remove use of single line functions Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 5/8] mfd: ti_am335x_tscadc: Rename regmap_tscadc to regmap "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 5/8] mfd: ti_am335x_tscadc: Rename regmap_tscadc to regmap Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 7/8] iio: adc: ti_am335x_adc: use variable names for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 7/8] iio: adc: ti_am335x_adc: use variable names for sizeof() operator Jonathan Cameron <jic23@kernel.org> - 2016-06-03 14:20 +0200
[PATCH 8/8] Input: ti_am335x_tsc - use variable name for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 8/8] Input: ti_am335x_tsc - use variable name for sizeof() operator Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2016-06-01 20:40 +0200
[PATCH 6/8] mfd: ti_am335x_tscadc: use variable name for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
[PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev Dave Gerlach <d-gerlach@ti.com> - 2016-05-31 20:00 +0200
Re: [PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
[PATCH 2/8] iio: adc: ti_am335x_adc: use SIMPLE_DEV_PM_OPS helper macro "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
Re: [PATCH 2/8] iio: adc: ti_am335x_adc: use SIMPLE_DEV_PM_OPS helper macro Jonathan Cameron <jic23@kernel.org> - 2016-06-03 14:20 +0200
Re: [PATCH 0/8] TI AM335x TSC/ADC cleanup Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
csiph-web