Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1410442

[PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro

From "Andrew F. Davis" <afd@ti.com>
Newsgroups linux.kernel
Subject [PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro
Date 2016-05-31 19:10 +0200
Message-ID <rEVl1-5uA-39@gated-at.bofh.it> (permalink)
References <rEVkZ-5uA-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


Replace ifdefs with SIMPLE_DEV_PM_OPS helper macro.

Signed-off-by: Andrew F. Davis <afd@ti.com>
---
 drivers/mfd/ti_am335x_tscadc.c | 16 ++++------------
 1 file changed, 4 insertions(+), 12 deletions(-)

diff --git a/drivers/mfd/ti_am335x_tscadc.c b/drivers/mfd/ti_am335x_tscadc.c
index e4e4b22..644128b 100644
--- a/drivers/mfd/ti_am335x_tscadc.c
+++ b/drivers/mfd/ti_am335x_tscadc.c
@@ -310,8 +310,7 @@ static int ti_tscadc_remove(struct platform_device *pdev)
 	return 0;
 }
 
-#ifdef CONFIG_PM
-static int tscadc_suspend(struct device *dev)
+static int __maybe_unused tscadc_suspend(struct device *dev)
 {
 	struct ti_tscadc_dev	*tscadc_dev = dev_get_drvdata(dev);
 
@@ -321,7 +320,7 @@ static int tscadc_suspend(struct device *dev)
 	return 0;
 }
 
-static int tscadc_resume(struct device *dev)
+static int __maybe_unused tscadc_resume(struct device *dev)
 {
 	struct ti_tscadc_dev	*tscadc_dev = dev_get_drvdata(dev);
 	u32 ctrl;
@@ -347,14 +346,7 @@ static int tscadc_resume(struct device *dev)
 	return 0;
 }
 
-static const struct dev_pm_ops tscadc_pm_ops = {
-	.suspend = tscadc_suspend,
-	.resume = tscadc_resume,
-};
-#define TSCADC_PM_OPS (&tscadc_pm_ops)
-#else
-#define TSCADC_PM_OPS NULL
-#endif
+static SIMPLE_DEV_PM_OPS(tscadc_pm_ops, tscadc_suspend, tscadc_resume);
 
 static const struct of_device_id ti_tscadc_dt_ids[] = {
 	{ .compatible = "ti,am3359-tscadc", },
@@ -365,7 +357,7 @@ MODULE_DEVICE_TABLE(of, ti_tscadc_dt_ids);
 static struct platform_driver ti_tscadc_driver = {
 	.driver = {
 		.name   = "ti_am3359-tscadc",
-		.pm	= TSCADC_PM_OPS,
+		.pm	= &tscadc_pm_ops,
 		.of_match_table = ti_tscadc_dt_ids,
 	},
 	.probe	= ti_tscadc_probe,
-- 
2.8.3

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 0/8] TI AM335x TSC/ADC cleanup "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
  [PATCH 3/8] mfd: ti_am335x_tscadc: Remove use of single line functions "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
    Re: [PATCH 3/8] mfd: ti_am335x_tscadc: Remove use of single line  functions Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
  [PATCH 5/8] mfd: ti_am335x_tscadc: Rename regmap_tscadc to regmap "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
    Re: [PATCH 5/8] mfd: ti_am335x_tscadc: Rename regmap_tscadc to regmap Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
  [PATCH 7/8] iio: adc: ti_am335x_adc: use variable names for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
    Re: [PATCH 7/8] iio: adc: ti_am335x_adc: use variable names for  sizeof() operator Jonathan Cameron <jic23@kernel.org> - 2016-06-03 14:20 +0200
  [PATCH 8/8] Input: ti_am335x_tsc - use variable name for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
    Re: [PATCH 8/8] Input: ti_am335x_tsc - use variable name for  sizeof() operator Dmitry Torokhov <dmitry.torokhov@gmail.com> - 2016-06-01 20:40 +0200
  [PATCH 6/8] mfd: ti_am335x_tscadc: use variable name for sizeof() operator "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
  [PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper macro "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
    Re: [PATCH 1/8] mfd: ti_am335x_tscadc: Use SIMPLE_DEV_PM_OPS helper  macro Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
  [PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when refrencing ti_tscadc_dev "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
    Re: [PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when  refrencing ti_tscadc_dev Dave Gerlach <d-gerlach@ti.com> - 2016-05-31 20:00 +0200
    Re: [PATCH 4/8] mfd: ti_am335x_tscadc: Unify variable naming when  refrencing ti_tscadc_dev Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200
  [PATCH 2/8] iio: adc: ti_am335x_adc: use SIMPLE_DEV_PM_OPS helper macro "Andrew F. Davis" <afd@ti.com> - 2016-05-31 19:10 +0200
    Re: [PATCH 2/8] iio: adc: ti_am335x_adc: use SIMPLE_DEV_PM_OPS helper  macro Jonathan Cameron <jic23@kernel.org> - 2016-06-03 14:20 +0200
  Re: [PATCH 0/8] TI AM335x TSC/ADC cleanup Lee Jones <lee.jones@linaro.org> - 2016-06-08 17:40 +0200

csiph-web