Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1465356 > unrolled thread

[PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module

Started byJavier Martinez Canillas <javier@osg.samsung.com>
First post2016-08-18 15:50 +0200
Last post2016-08-22 09:50 +0200
Articles 7 — 4 participants

Back to article view | Back to linux.kernel


Contents

  [PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
    [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
      Re: [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <balbi@kernel.org> - 2016-08-18 16:00 +0200
    [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
      Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <felipe.balbi@linux.intel.com> - 2016-08-18 15:50 +0200
      Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <felipe.balbi@linux.intel.com> - 2016-08-18 15:50 +0200
      Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking  for built-in or module Johan Hovold <johan@kernel.org> - 2016-08-22 09:50 +0200

#1465356 — [PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module

FromJavier Martinez Canillas <javier@osg.samsung.com>
Date2016-08-18 15:50 +0200
Subject[PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module
Message-ID<s7vRL-sf-5@gated-at.bofh.it>
The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.

Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.

Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
---

 drivers/usb/core/hcd.c           | 2 +-
 drivers/usb/core/otg_whitelist.h | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
index d2e3f655c26f..0e2c733d20c3 100644
--- a/drivers/usb/core/hcd.c
+++ b/drivers/usb/core/hcd.c
@@ -3033,7 +3033,7 @@ EXPORT_SYMBOL_GPL(usb_hcd_platform_shutdown);
 
 /*-------------------------------------------------------------------------*/
 
-#if defined(CONFIG_USB_MON) || defined(CONFIG_USB_MON_MODULE)
+#if IS_ENABLED(CONFIG_USB_MON)
 
 const struct usb_mon_operations *mon_ops;
 
diff --git a/drivers/usb/core/otg_whitelist.h b/drivers/usb/core/otg_whitelist.h
index a95b0c989c21..085049d37d7a 100644
--- a/drivers/usb/core/otg_whitelist.h
+++ b/drivers/usb/core/otg_whitelist.h
@@ -38,7 +38,7 @@ static struct usb_device_id whitelist_table[] = {
 { USB_DEVICE(0x0525, 0xa4a2), },
 #endif
 
-#if	defined(CONFIG_USB_TEST) || defined(CONFIG_USB_TEST_MODULE)
+#if	IS_ENABLED(CONFIG_USB_TEST)
 /* gadget zero, for testing */
 { USB_DEVICE(0x0525, 0xa4a0), },
 #endif
-- 
2.5.5

[toc] | [next] | [standalone]


#1465357 — [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module

FromJavier Martinez Canillas <javier@osg.samsung.com>
Date2016-08-18 15:50 +0200
Subject[PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module
Message-ID<s7vRL-sf-3@gated-at.bofh.it>
In reply to#1465356
The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.

Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.

Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
---

 drivers/usb/gadget/udc/omap_udc.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/drivers/usb/gadget/udc/omap_udc.c b/drivers/usb/gadget/udc/omap_udc.c
index 9b7d39484ed3..a8709f9e5648 100644
--- a/drivers/usb/gadget/udc/omap_udc.c
+++ b/drivers/usb/gadget/udc/omap_udc.c
@@ -2875,7 +2875,7 @@ bad_on_1710:
 	xceiv = NULL;
 	/* "udc" is now valid */
 	pullup_disable(udc);
-#if	defined(CONFIG_USB_OHCI_HCD) || defined(CONFIG_USB_OHCI_HCD_MODULE)
+#if	IS_ENABLED(CONFIG_USB_OHCI_HCD)
 	udc->gadget.is_otg = (config->otg != 0);
 #endif
 
-- 
2.5.5

[toc] | [prev] | [next] | [standalone]


#1465397 — Re: [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module

FromFelipe Balbi <balbi@kernel.org>
Date2016-08-18 16:00 +0200
SubjectRe: [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module
Message-ID<s7w1s-vD-53@gated-at.bofh.it>
In reply to#1465357

[Multipart message — attachments visible in raw view] — view raw

Javier Martinez Canillas <javier@osg.samsung.com> writes:

> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
>
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
>
> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

Acked-by: Felipe Balbi <felipe.balbi@linux.intel.com>

> ---
>
>  drivers/usb/gadget/udc/omap_udc.c | 2 +-
>  1 file changed, 1 insertion(+), 1 deletion(-)
>
> diff --git a/drivers/usb/gadget/udc/omap_udc.c b/drivers/usb/gadget/udc/omap_udc.c
> index 9b7d39484ed3..a8709f9e5648 100644
> --- a/drivers/usb/gadget/udc/omap_udc.c
> +++ b/drivers/usb/gadget/udc/omap_udc.c
> @@ -2875,7 +2875,7 @@ bad_on_1710:
>  	xceiv = NULL;
>  	/* "udc" is now valid */
>  	pullup_disable(udc);
> -#if	defined(CONFIG_USB_OHCI_HCD) || defined(CONFIG_USB_OHCI_HCD_MODULE)
> +#if	IS_ENABLED(CONFIG_USB_OHCI_HCD)
>  	udc->gadget.is_otg = (config->otg != 0);
>  #endif
>  
> -- 
> 2.5.5
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

-- 
balbi

[toc] | [prev] | [next] | [standalone]


#1465361 — [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module

FromJavier Martinez Canillas <javier@osg.samsung.com>
Date2016-08-18 15:50 +0200
Subject[PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module
Message-ID<s7vRM-sf-21@gated-at.bofh.it>
In reply to#1465356
The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.

Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.

Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
---

 drivers/usb/serial/keyspan_pda.c | 4 ++--
 1 file changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/serial/keyspan_pda.c b/drivers/usb/serial/keyspan_pda.c
index 4f7e072e4e00..e49ad0c63ad8 100644
--- a/drivers/usb/serial/keyspan_pda.c
+++ b/drivers/usb/serial/keyspan_pda.c
@@ -30,12 +30,12 @@
 #include <linux/usb/ezusb.h>
 
 /* make a simple define to handle if we are compiling keyspan_pda or xircom support */
-#if defined(CONFIG_USB_SERIAL_KEYSPAN_PDA) || defined(CONFIG_USB_SERIAL_KEYSPAN_PDA_MODULE)
+#if IS_ENABLED(CONFIG_USB_SERIAL_KEYSPAN_PDA)
 	#define KEYSPAN
 #else
 	#undef KEYSPAN
 #endif
-#if defined(CONFIG_USB_SERIAL_XIRCOM) || defined(CONFIG_USB_SERIAL_XIRCOM_MODULE)
+#if IS_ENABLED(CONFIG_USB_SERIAL_XIRCOM)
 	#define XIRCOM
 #else
 	#undef XIRCOM
-- 
2.5.5

[toc] | [prev] | [next] | [standalone]


#1465365 — Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module

FromFelipe Balbi <felipe.balbi@linux.intel.com>
Date2016-08-18 15:50 +0200
SubjectRe: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module
Message-ID<s7vRM-sf-37@gated-at.bofh.it>
In reply to#1465361

[Multipart message — attachments visible in raw view] — view raw

Hi,

Felipe Balbi <felipe.balbi@linux.intel.com> writes:
> Hi,
>
> Javier Martinez Canillas <javier@osg.samsung.com> writes:
>> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
>> built-in or as a module, use that macro instead of open coding the same.
>>
>> Using the macro makes the code more readable by helping abstract away some
>> of the Kconfig built-in and module enable details.
>>
>> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
>
> Assuming this is going through trivial tree:
>
> Acked-by: Felipe Balbi <felipe.balbi@linux.intel.com>

sorry, this was supposed to be for omap_udc patch.

-- 
balbi

[toc] | [prev] | [next] | [standalone]


#1465370 — Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module

FromFelipe Balbi <felipe.balbi@linux.intel.com>
Date2016-08-18 15:50 +0200
SubjectRe: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module
Message-ID<s7vRM-sf-39@gated-at.bofh.it>
In reply to#1465361

[Multipart message — attachments visible in raw view] — view raw

Hi,

Javier Martinez Canillas <javier@osg.samsung.com> writes:
> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
>
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
>
> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

Assuming this is going through trivial tree:

Acked-by: Felipe Balbi <felipe.balbi@linux.intel.com>

thanks

> ---
>
>  drivers/usb/serial/keyspan_pda.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/usb/serial/keyspan_pda.c b/drivers/usb/serial/keyspan_pda.c
> index 4f7e072e4e00..e49ad0c63ad8 100644
> --- a/drivers/usb/serial/keyspan_pda.c
> +++ b/drivers/usb/serial/keyspan_pda.c
> @@ -30,12 +30,12 @@
>  #include <linux/usb/ezusb.h>
>  
>  /* make a simple define to handle if we are compiling keyspan_pda or xircom support */
> -#if defined(CONFIG_USB_SERIAL_KEYSPAN_PDA) || defined(CONFIG_USB_SERIAL_KEYSPAN_PDA_MODULE)
> +#if IS_ENABLED(CONFIG_USB_SERIAL_KEYSPAN_PDA)
>  	#define KEYSPAN
>  #else
>  	#undef KEYSPAN
>  #endif
> -#if defined(CONFIG_USB_SERIAL_XIRCOM) || defined(CONFIG_USB_SERIAL_XIRCOM_MODULE)
> +#if IS_ENABLED(CONFIG_USB_SERIAL_XIRCOM)
>  	#define XIRCOM
>  #else
>  	#undef XIRCOM
> -- 
> 2.5.5
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

-- 
balbi

[toc] | [prev] | [next] | [standalone]


#1467427 — Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module

FromJohan Hovold <johan@kernel.org>
Date2016-08-22 09:50 +0200
SubjectRe: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module
Message-ID<s8S9z-3nT-9@gated-at.bofh.it>
In reply to#1465361
On Thu, Aug 18, 2016 at 09:45:06AM -0400, Javier Martinez Canillas wrote:
> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
> 
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
> 
> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

Now applied, thanks.

Johan

[toc] | [prev] | [standalone]


Back to top | Article view | linux.kernel


csiph-web