Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1465370

Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module

From Felipe Balbi <felipe.balbi@linux.intel.com>
Newsgroups linux.kernel
Subject Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module
Date 2016-08-18 15:50 +0200
Message-ID <s7vRM-sf-39@gated-at.bofh.it> (permalink)
References <s7vRL-sf-5@gated-at.bofh.it> <s7vRM-sf-21@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


[Multipart message — attachments visible in raw view] - view raw

Hi,

Javier Martinez Canillas <javier@osg.samsung.com> writes:
> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
> built-in or as a module, use that macro instead of open coding the same.
>
> Using the macro makes the code more readable by helping abstract away some
> of the Kconfig built-in and module enable details.
>
> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>

Assuming this is going through trivial tree:

Acked-by: Felipe Balbi <felipe.balbi@linux.intel.com>

thanks

> ---
>
>  drivers/usb/serial/keyspan_pda.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
>
> diff --git a/drivers/usb/serial/keyspan_pda.c b/drivers/usb/serial/keyspan_pda.c
> index 4f7e072e4e00..e49ad0c63ad8 100644
> --- a/drivers/usb/serial/keyspan_pda.c
> +++ b/drivers/usb/serial/keyspan_pda.c
> @@ -30,12 +30,12 @@
>  #include <linux/usb/ezusb.h>
>  
>  /* make a simple define to handle if we are compiling keyspan_pda or xircom support */
> -#if defined(CONFIG_USB_SERIAL_KEYSPAN_PDA) || defined(CONFIG_USB_SERIAL_KEYSPAN_PDA_MODULE)
> +#if IS_ENABLED(CONFIG_USB_SERIAL_KEYSPAN_PDA)
>  	#define KEYSPAN
>  #else
>  	#undef KEYSPAN
>  #endif
> -#if defined(CONFIG_USB_SERIAL_XIRCOM) || defined(CONFIG_USB_SERIAL_XIRCOM_MODULE)
> +#if IS_ENABLED(CONFIG_USB_SERIAL_XIRCOM)
>  	#define XIRCOM
>  #else
>  	#undef XIRCOM
> -- 
> 2.5.5
>
> --
> To unsubscribe from this list: send the line "unsubscribe linux-usb" in
> the body of a message to majordomo@vger.kernel.org
> More majordomo info at  http://vger.kernel.org/majordomo-info.html

-- 
balbi

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
  [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
    Re: [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <balbi@kernel.org> - 2016-08-18 16:00 +0200
  [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
    Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <felipe.balbi@linux.intel.com> - 2016-08-18 15:50 +0200
    Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <felipe.balbi@linux.intel.com> - 2016-08-18 15:50 +0200
    Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking  for built-in or module Johan Hovold <johan@kernel.org> - 2016-08-22 09:50 +0200

csiph-web