Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1465356

[PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module

From Javier Martinez Canillas <javier@osg.samsung.com>
Newsgroups linux.kernel
Subject [PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module
Date 2016-08-18 15:50 +0200
Message-ID <s7vRL-sf-5@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either
built-in or as a module, use that macro instead of open coding the same.

Using the macro makes the code more readable by helping abstract away some
of the Kconfig built-in and module enable details.

Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com>
---

 drivers/usb/core/hcd.c           | 2 +-
 drivers/usb/core/otg_whitelist.h | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/usb/core/hcd.c b/drivers/usb/core/hcd.c
index d2e3f655c26f..0e2c733d20c3 100644
--- a/drivers/usb/core/hcd.c
+++ b/drivers/usb/core/hcd.c
@@ -3033,7 +3033,7 @@ EXPORT_SYMBOL_GPL(usb_hcd_platform_shutdown);
 
 /*-------------------------------------------------------------------------*/
 
-#if defined(CONFIG_USB_MON) || defined(CONFIG_USB_MON_MODULE)
+#if IS_ENABLED(CONFIG_USB_MON)
 
 const struct usb_mon_operations *mon_ops;
 
diff --git a/drivers/usb/core/otg_whitelist.h b/drivers/usb/core/otg_whitelist.h
index a95b0c989c21..085049d37d7a 100644
--- a/drivers/usb/core/otg_whitelist.h
+++ b/drivers/usb/core/otg_whitelist.h
@@ -38,7 +38,7 @@ static struct usb_device_id whitelist_table[] = {
 { USB_DEVICE(0x0525, 0xa4a2), },
 #endif
 
-#if	defined(CONFIG_USB_TEST) || defined(CONFIG_USB_TEST_MODULE)
+#if	IS_ENABLED(CONFIG_USB_TEST)
 /* gadget zero, for testing */
 { USB_DEVICE(0x0525, 0xa4a0), },
 #endif
-- 
2.5.5

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
  [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
    Re: [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <balbi@kernel.org> - 2016-08-18 16:00 +0200
  [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
    Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <felipe.balbi@linux.intel.com> - 2016-08-18 15:50 +0200
    Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <felipe.balbi@linux.intel.com> - 2016-08-18 15:50 +0200
    Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking  for built-in or module Johan Hovold <johan@kernel.org> - 2016-08-22 09:50 +0200

csiph-web