Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1465357
| From | Javier Martinez Canillas <javier@osg.samsung.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module |
| Date | 2016-08-18 15:50 +0200 |
| Message-ID | <s7vRL-sf-3@gated-at.bofh.it> (permalink) |
| References | <s7vRL-sf-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either built-in or as a module, use that macro instead of open coding the same. Using the macro makes the code more readable by helping abstract away some of the Kconfig built-in and module enable details. Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com> --- drivers/usb/gadget/udc/omap_udc.c | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-) diff --git a/drivers/usb/gadget/udc/omap_udc.c b/drivers/usb/gadget/udc/omap_udc.c index 9b7d39484ed3..a8709f9e5648 100644 --- a/drivers/usb/gadget/udc/omap_udc.c +++ b/drivers/usb/gadget/udc/omap_udc.c @@ -2875,7 +2875,7 @@ bad_on_1710: xceiv = NULL; /* "udc" is now valid */ pullup_disable(udc); -#if defined(CONFIG_USB_OHCI_HCD) || defined(CONFIG_USB_OHCI_HCD_MODULE) +#if IS_ENABLED(CONFIG_USB_OHCI_HCD) udc->gadget.is_otg = (config->otg != 0); #endif -- 2.5.5
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
[PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
Re: [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <balbi@kernel.org> - 2016-08-18 16:00 +0200
[PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <felipe.balbi@linux.intel.com> - 2016-08-18 15:50 +0200
Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <felipe.balbi@linux.intel.com> - 2016-08-18 15:50 +0200
Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Johan Hovold <johan@kernel.org> - 2016-08-22 09:50 +0200
csiph-web