Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1465365
| From | Felipe Balbi <felipe.balbi@linux.intel.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module |
| Date | 2016-08-18 15:50 +0200 |
| Message-ID | <s7vRM-sf-37@gated-at.bofh.it> (permalink) |
| References | <s7vRL-sf-5@gated-at.bofh.it> <s7vRM-sf-21@gated-at.bofh.it> <s7vRM-sf-39@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
[Multipart message — attachments visible in raw view] - view raw
Hi, Felipe Balbi <felipe.balbi@linux.intel.com> writes: > Hi, > > Javier Martinez Canillas <javier@osg.samsung.com> writes: >> The IS_ENABLED() macro checks if a Kconfig symbol has been enabled either >> built-in or as a module, use that macro instead of open coding the same. >> >> Using the macro makes the code more readable by helping abstract away some >> of the Kconfig built-in and module enable details. >> >> Signed-off-by: Javier Martinez Canillas <javier@osg.samsung.com> > > Assuming this is going through trivial tree: > > Acked-by: Felipe Balbi <felipe.balbi@linux.intel.com> sorry, this was supposed to be for omap_udc patch. -- balbi
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 1/3] usb: core: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
[PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
Re: [PATCH 2/3] usb: gadget: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <balbi@kernel.org> - 2016-08-18 16:00 +0200
[PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Javier Martinez Canillas <javier@osg.samsung.com> - 2016-08-18 15:50 +0200
Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <felipe.balbi@linux.intel.com> - 2016-08-18 15:50 +0200
Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Felipe Balbi <felipe.balbi@linux.intel.com> - 2016-08-18 15:50 +0200
Re: [PATCH 3/3] USB: serial: use IS_ENABLED() instead of checking for built-in or module Johan Hovold <johan@kernel.org> - 2016-08-22 09:50 +0200
csiph-web