Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1652112

[PATCH 05/22] uuid: remove uuid_be defintions from the uapi header

From Christoph Hellwig <hch@lst.de>
Newsgroups linux.kernel
Subject [PATCH 05/22] uuid: remove uuid_be defintions from the uapi header
Date 2017-05-28 12:30 +0200
Message-ID <tM3Cr-Hq-45@gated-at.bofh.it> (permalink)
References <tM3Cp-Hq-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


We don't use uuid_be and the UUID_BE constants in any uapi headers, so make
them private to the kernel.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Amir Goldstein <amir73il@gmail.com>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 include/linux/uuid.h      | 15 +++++++++++++++
 include/uapi/linux/uuid.h | 16 ----------------
 2 files changed, 15 insertions(+), 16 deletions(-)

diff --git a/include/linux/uuid.h b/include/linux/uuid.h
index 2d095fc60204..30fb13018e29 100644
--- a/include/linux/uuid.h
+++ b/include/linux/uuid.h
@@ -18,6 +18,21 @@
 
 #include <uapi/linux/uuid.h>
 
+typedef struct {
+	__u8 b[16];
+} uuid_be;
+
+#define UUID_BE(a, b, c, d0, d1, d2, d3, d4, d5, d6, d7)		\
+((uuid_be)								\
+{{ ((a) >> 24) & 0xff, ((a) >> 16) & 0xff, ((a) >> 8) & 0xff, (a) & 0xff, \
+   ((b) >> 8) & 0xff, (b) & 0xff,					\
+   ((c) >> 8) & 0xff, (c) & 0xff,					\
+   (d0), (d1), (d2), (d3), (d4), (d5), (d6), (d7) }})
+
+#define NULL_UUID_BE							\
+	UUID_BE(0x00000000, 0x0000, 0x0000, 0x00, 0x00, 0x00, 0x00,	\
+		0x00, 0x00, 0x00, 0x00)
+
 /*
  * The length of a UUID string ("aaaaaaaa-bbbb-cccc-dddd-eeeeeeeeeeee")
  * not including trailing NUL.
diff --git a/include/uapi/linux/uuid.h b/include/uapi/linux/uuid.h
index 3738e5fb6a4d..0099756c4bac 100644
--- a/include/uapi/linux/uuid.h
+++ b/include/uapi/linux/uuid.h
@@ -24,10 +24,6 @@ typedef struct {
 	__u8 b[16];
 } uuid_le;
 
-typedef struct {
-	__u8 b[16];
-} uuid_be;
-
 #define UUID_LE(a, b, c, d0, d1, d2, d3, d4, d5, d6, d7)		\
 ((uuid_le)								\
 {{ (a) & 0xff, ((a) >> 8) & 0xff, ((a) >> 16) & 0xff, ((a) >> 24) & 0xff, \
@@ -35,20 +31,8 @@ typedef struct {
    (c) & 0xff, ((c) >> 8) & 0xff,					\
    (d0), (d1), (d2), (d3), (d4), (d5), (d6), (d7) }})
 
-#define UUID_BE(a, b, c, d0, d1, d2, d3, d4, d5, d6, d7)		\
-((uuid_be)								\
-{{ ((a) >> 24) & 0xff, ((a) >> 16) & 0xff, ((a) >> 8) & 0xff, (a) & 0xff, \
-   ((b) >> 8) & 0xff, (b) & 0xff,					\
-   ((c) >> 8) & 0xff, (c) & 0xff,					\
-   (d0), (d1), (d2), (d3), (d4), (d5), (d6), (d7) }})
-
 #define NULL_UUID_LE							\
 	UUID_LE(0x00000000, 0x0000, 0x0000, 0x00, 0x00, 0x00, 0x00,	\
 		0x00, 0x00, 0x00, 0x00)
 
-#define NULL_UUID_BE							\
-	UUID_BE(0x00000000, 0x0000, 0x0000, 0x00, 0x00, 0x00, 0x00,	\
-		0x00, 0x00, 0x00, 0x00)
-
-
 #endif /* _UAPI_LINUX_UUID_H_ */
-- 
2.11.0

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

cleanup UUID types V5 Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 15/22] fs: switch ->s_uuid to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 12/22] xfs: use the common helper uuid_is_null() Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 02/22] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 18/22] sysctl: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 04/22] md: namespace private helper names Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 22/22] MAINTAINERS: add uuid entry Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 21/22] tmpfs: generate random sb->s_uuid Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 19/22] nvme: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 06/22] uuid: rename uuid types Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 08/22] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 14/22] ima/policy: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 13/22] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 07/22] uuid: don't export guid_index and uuid_index Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 03/22] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 20/22] scsi_debug: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 16/22] overlayfs: use uuid_t instead of uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 05/22] uuid: remove uuid_be defintions from the uapi header Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200

csiph-web