Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1652108

[PATCH 07/22] uuid: don't export guid_index and uuid_index

From Christoph Hellwig <hch@lst.de>
Newsgroups linux.kernel
Subject [PATCH 07/22] uuid: don't export guid_index and uuid_index
Date 2017-05-28 12:30 +0200
Message-ID <tM3Cr-Hq-43@gated-at.bofh.it> (permalink)
References <tM3Cp-Hq-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


These are only used in uuid.c and vsprintf.c and aren't something modules
should use directly.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Amir Goldstein <amir73il@gmail.com>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 lib/uuid.c | 2 --
 1 file changed, 2 deletions(-)

diff --git a/lib/uuid.c b/lib/uuid.c
index f80dc63f6ca8..003bf6823003 100644
--- a/lib/uuid.c
+++ b/lib/uuid.c
@@ -22,9 +22,7 @@
 #include <linux/random.h>
 
 const u8 guid_index[16] = {3,2,1,0,5,4,7,6,8,9,10,11,12,13,14,15};
-EXPORT_SYMBOL(guid_index);
 const u8 uuid_index[16] = {0,1,2,3,4,5,6,7,8,9,10,11,12,13,14,15};
-EXPORT_SYMBOL(uuid_index);
 
 /***************************************************************
  * Random UUID interface
-- 
2.11.0

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

cleanup UUID types V5 Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 15/22] fs: switch ->s_uuid to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 12/22] xfs: use the common helper uuid_is_null() Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 02/22] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 18/22] sysctl: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 04/22] md: namespace private helper names Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 22/22] MAINTAINERS: add uuid entry Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 21/22] tmpfs: generate random sb->s_uuid Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 19/22] nvme: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 06/22] uuid: rename uuid types Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 08/22] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 14/22] ima/policy: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 13/22] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 07/22] uuid: don't export guid_index and uuid_index Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 03/22] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 20/22] scsi_debug: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 16/22] overlayfs: use uuid_t instead of uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 05/22] uuid: remove uuid_be defintions from the uapi header Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200

csiph-web