Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1652104
| From | Christoph Hellwig <hch@lst.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 14/22] ima/policy: switch to use uuid_t |
| Date | 2017-05-28 12:30 +0200 |
| Message-ID | <tM3Cr-Hq-37@gated-at.bofh.it> (permalink) |
| References | <tM3Cp-Hq-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Amir Goldstein <amir73il@gmail.com>
Acked-by: Mimi Zohar <zohar@linux.vnet.ibm.com>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
security/integrity/ima/ima_policy.c | 11 +++++------
1 file changed, 5 insertions(+), 6 deletions(-)
diff --git a/security/integrity/ima/ima_policy.c b/security/integrity/ima/ima_policy.c
index 49fbc3e8f012..da3e7d50e0d7 100644
--- a/security/integrity/ima/ima_policy.c
+++ b/security/integrity/ima/ima_policy.c
@@ -61,7 +61,7 @@ struct ima_rule_entry {
enum ima_hooks func;
int mask;
unsigned long fsmagic;
- u8 fsuuid[16];
+ uuid_t fsuuid;
kuid_t uid;
kuid_t fowner;
bool (*uid_op)(kuid_t, kuid_t); /* Handlers for operators */
@@ -244,7 +244,7 @@ static bool ima_match_rules(struct ima_rule_entry *rule, struct inode *inode,
&& rule->fsmagic != inode->i_sb->s_magic)
return false;
if ((rule->flags & IMA_FSUUID) &&
- memcmp(rule->fsuuid, inode->i_sb->s_uuid, sizeof(rule->fsuuid)))
+ memcmp(&rule->fsuuid, inode->i_sb->s_uuid, sizeof(rule->fsuuid)))
return false;
if ((rule->flags & IMA_UID) && !rule->uid_op(cred->uid, rule->uid))
return false;
@@ -711,13 +711,12 @@ static int ima_parse_rule(char *rule, struct ima_rule_entry *entry)
case Opt_fsuuid:
ima_log_string(ab, "fsuuid", args[0].from);
- if (memchr_inv(entry->fsuuid, 0x00,
- sizeof(entry->fsuuid))) {
+ if (uuid_is_null(&entry->fsuuid)) {
result = -EINVAL;
break;
}
- result = uuid_to_bin(args[0].from, (uuid_t *)&entry->fsuuid);
+ result = uuid_to_bin(args[0].from, &entry->fsuuid);
if (!result)
entry->flags |= IMA_FSUUID;
break;
@@ -1086,7 +1085,7 @@ int ima_policy_show(struct seq_file *m, void *v)
}
if (entry->flags & IMA_FSUUID) {
- seq_printf(m, "fsuuid=%pU", entry->fsuuid);
+ seq_printf(m, "fsuuid=%pU", &entry->fsuuid);
seq_puts(m, " ");
}
--
2.11.0
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
cleanup UUID types V5 Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 15/22] fs: switch ->s_uuid to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 12/22] xfs: use the common helper uuid_is_null() Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 02/22] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 18/22] sysctl: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 04/22] md: namespace private helper names Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 22/22] MAINTAINERS: add uuid entry Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 21/22] tmpfs: generate random sb->s_uuid Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 19/22] nvme: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 06/22] uuid: rename uuid types Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 08/22] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 14/22] ima/policy: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 13/22] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 07/22] uuid: don't export guid_index and uuid_index Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 03/22] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 20/22] scsi_debug: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 16/22] overlayfs: use uuid_t instead of uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 05/22] uuid: remove uuid_be defintions from the uapi header Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
csiph-web