Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1652107

[PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it

From Christoph Hellwig <hch@lst.de>
Newsgroups linux.kernel
Subject [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it
Date 2017-05-28 12:30 +0200
Message-ID <tM3Cr-Hq-41@gated-at.bofh.it> (permalink)
References <tM3Cp-Hq-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


And switch to use uuid_t instead of the old uuid_be type.

Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Amir Goldstein <amir73il@gmail.com>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
 arch/s390/include/asm/sysinfo.h | 4 ++--
 arch/s390/kernel/sysinfo.c      | 2 +-
 2 files changed, 3 insertions(+), 3 deletions(-)

diff --git a/arch/s390/include/asm/sysinfo.h b/arch/s390/include/asm/sysinfo.h
index e784bed6ed7f..2b498e58b914 100644
--- a/arch/s390/include/asm/sysinfo.h
+++ b/arch/s390/include/asm/sysinfo.h
@@ -109,7 +109,7 @@ struct sysinfo_2_2_2 {
 	unsigned short cpus_shared;
 	char reserved_4[3];
 	unsigned char vsne;
-	uuid_be uuid;
+	uuid_t uuid;
 	char reserved_5[160];
 	char ext_name[256];
 };
@@ -134,7 +134,7 @@ struct sysinfo_3_2_2 {
 		char reserved_1[3];
 		unsigned char evmne;
 		unsigned int reserved_2;
-		uuid_be uuid;
+		uuid_t uuid;
 	} vm[8];
 	char reserved_3[1504];
 	char ext_names[8][256];
diff --git a/arch/s390/kernel/sysinfo.c b/arch/s390/kernel/sysinfo.c
index eefcb54872a5..fb869b103825 100644
--- a/arch/s390/kernel/sysinfo.c
+++ b/arch/s390/kernel/sysinfo.c
@@ -242,7 +242,7 @@ static void print_ext_name(struct seq_file *m, int lvl,
 
 static void print_uuid(struct seq_file *m, int i, struct sysinfo_3_2_2 *info)
 {
-	if (!memcmp(&info->vm[i].uuid, &NULL_UUID_BE, sizeof(uuid_be)))
+	if (uuid_is_null(&info->vm[i].uuid))
 		return;
 	seq_printf(m, "VM%02d UUID:            %pUb\n", i, &info->vm[i].uuid);
 }
-- 
2.11.0

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

cleanup UUID types V5 Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 15/22] fs: switch ->s_uuid to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 12/22] xfs: use the common helper uuid_is_null() Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 02/22] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 18/22] sysctl: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 04/22] md: namespace private helper names Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 22/22] MAINTAINERS: add uuid entry Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 21/22] tmpfs: generate random sb->s_uuid Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 19/22] nvme: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 06/22] uuid: rename uuid types Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 08/22] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 14/22] ima/policy: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 13/22] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 07/22] uuid: don't export guid_index and uuid_index Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 03/22] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 20/22] scsi_debug: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 16/22] overlayfs: use uuid_t instead of uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
  [PATCH 05/22] uuid: remove uuid_be defintions from the uapi header Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200

csiph-web