Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1652098
| From | Christoph Hellwig <hch@lst.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 04/22] md: namespace private helper names |
| Date | 2017-05-28 12:30 +0200 |
| Message-ID | <tM3Cq-Hq-25@gated-at.bofh.it> (permalink) |
| References | <tM3Cp-Hq-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Amir Goldstein <amir73il@gmail.com>
The md private helper uuid_equal() collides with a generic helper
of the same name.
Rename the md private helper to md_uuid_equal() and do the same for
md_sb_equal().
Signed-off-by: Amir Goldstein <amir73il@gmail.com>
Signed-off-by: Christoph Hellwig <hch@lst.de>
Reviewed-by: Shaohua Li <shli@kernel.org>
Reviewed-by: Andy Shevchenko <andriy.shevchenko@linux.intel.com>
---
drivers/md/md.c | 8 ++++----
1 file changed, 4 insertions(+), 4 deletions(-)
diff --git a/drivers/md/md.c b/drivers/md/md.c
index 10367ffe92e3..b9ab268ba7f9 100644
--- a/drivers/md/md.c
+++ b/drivers/md/md.c
@@ -825,7 +825,7 @@ static int read_disk_sb(struct md_rdev *rdev, int size)
return -EINVAL;
}
-static int uuid_equal(mdp_super_t *sb1, mdp_super_t *sb2)
+static int md_uuid_equal(mdp_super_t *sb1, mdp_super_t *sb2)
{
return sb1->set_uuid0 == sb2->set_uuid0 &&
sb1->set_uuid1 == sb2->set_uuid1 &&
@@ -833,7 +833,7 @@ static int uuid_equal(mdp_super_t *sb1, mdp_super_t *sb2)
sb1->set_uuid3 == sb2->set_uuid3;
}
-static int sb_equal(mdp_super_t *sb1, mdp_super_t *sb2)
+static int md_sb_equal(mdp_super_t *sb1, mdp_super_t *sb2)
{
int ret;
mdp_super_t *tmp1, *tmp2;
@@ -1025,12 +1025,12 @@ static int super_90_load(struct md_rdev *rdev, struct md_rdev *refdev, int minor
} else {
__u64 ev1, ev2;
mdp_super_t *refsb = page_address(refdev->sb_page);
- if (!uuid_equal(refsb, sb)) {
+ if (!md_uuid_equal(refsb, sb)) {
pr_warn("md: %s has different UUID to %s\n",
b, bdevname(refdev->bdev,b2));
goto abort;
}
- if (!sb_equal(refsb, sb)) {
+ if (!md_sb_equal(refsb, sb)) {
pr_warn("md: %s has same UUID but different superblock to %s\n",
b, bdevname(refdev->bdev, b2));
goto abort;
--
2.11.0
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
cleanup UUID types V5 Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 15/22] fs: switch ->s_uuid to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 12/22] xfs: use the common helper uuid_is_null() Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 02/22] xfs: use uuid_copy() helper to abstract uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 18/22] sysctl: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 04/22] md: namespace private helper names Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 22/22] MAINTAINERS: add uuid entry Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 21/22] tmpfs: generate random sb->s_uuid Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 19/22] nvme: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 06/22] uuid: rename uuid types Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 08/22] uuid: hoist helpers uuid_equal() and uuid_copy() from xfs Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 14/22] ima/policy: switch to use uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 13/22] block: remove blk_part_pack_uuid Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 10/22] S390/sysinfo: use uuid_is_null instead of opencoding it Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 07/22] uuid: don't export guid_index and uuid_index Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 03/22] xfs: use uuid_be to implement the uuid_t type Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 20/22] scsi_debug: switch to uuid_t Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 16/22] overlayfs: use uuid_t instead of uuid_be Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200 [PATCH 05/22] uuid: remove uuid_be defintions from the uapi header Christoph Hellwig <hch@lst.de> - 2017-05-28 12:30 +0200
csiph-web