Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1556981
| From | Marek Vasut <marek.vasut@gmail.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations |
| Date | 2017-01-11 23:10 +0100 |
| Message-ID | <sYzfI-42A-39@gated-at.bofh.it> (permalink) |
| References | <sYxQC-34a-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 01/11/2017 09:34 PM, SF Markus Elfring wrote: > From: Markus Elfring <elfring@users.sourceforge.net> > Date: Wed, 11 Jan 2017 21:21:12 +0100 > > Several update suggestions were taken into account > from static source code analysis. The patch listing doesn't seem to match the content of the patchset ? The $subject are different ... > Markus Elfring (18): > Use kmalloc_array() in cfi_intelext_partition_fixup() > Improve another size determination in cfi_intelext_partition_fixup() > cfi_cmdset_0001: Add some spaces for better code readability > cfi_cmdset_0001: Delete an unnecessary variable initialisation in do_write_oneword() > cfi_cmdset_0001: Use common error handling code in do_write_oneword() > Use kcalloc() in cfi_intelext_setup() > One function call and an unnecessary check less in cfi_intelext_setup() > Rename a jump label in cfi_intelext_setup() > Use kmalloc_array() in cfi_amdstd_setup() > One function call less in cfi_amdstd_setup() after error detection > Rename a jump label in cfi_amdstd_setup() > cfi_cmdset_0002: Add some spaces for better code readability > cfi_cmdset_0002: Delete an unnecessary variable initialisation in do_write_oneword() > cfi_cmdset_0002: Use common error handling code in do_write_oneword() > Use kcalloc() in cfi_ppb_unlock() > Use kmalloc_array() in cfi_staa_setup() > Use common error handling code in cfi_staa_setup() > cfi_cmdset_0020: Add some spaces for better code readability > > drivers/mtd/chips/cfi_cmdset_0001.c | 165 +++++++++++++++++++----------------- > drivers/mtd/chips/cfi_cmdset_0002.c | 110 +++++++++++++----------- > drivers/mtd/chips/cfi_cmdset_0020.c | 127 ++++++++++++++------------- > 3 files changed, 214 insertions(+), 188 deletions(-) > -- Best regards, Marek Vasut
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
[PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:40 +0100
[PATCH 03/18] mtd-cfi_cmdset_0001: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
Re: [PATCH 03/18] mtd-cfi_cmdset_0001: Add some spaces for better code readability Dan Carpenter <dan.carpenter@oracle.com> - 2017-01-12 10:30 +0100
[PATCH 04/18] mtd-cfi_cmdset_0001: Delete an unnecessary variable initialisation in do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 07/18] mtd-cfi_cmdset_0001: One function call and an unnecessary check less in cfi_intelext_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 05/18] mtd-cfi_cmdset_0001: Use common error handling code in do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 09/18] mtd-cfi_cmdset_0002: Use kmalloc_array() in cfi_amdstd_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 11/18] mtd-cfi_cmdset_0002: Rename a jump label in cfi_amdstd_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 08/18] mtd-cfi_cmdset_0001: Rename a jump label in cfi_intelext_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 10/18] mtd-cfi_cmdset_0002: One function call less in cfi_amdstd_setup() after error detection SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 06/18] mtd-cfi_cmdset_0001: Use kcalloc() in cfi_intelext_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 14/18] mtd-cfi_cmdset_0002: Use common error handling code in do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
[PATCH 16/18] mtd-cfi_cmdset_0020: Use kmalloc_array() in cfi_staa_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
[PATCH 17/18] mtd-cfi_cmdset_0020: Use common error handling code in cfi_staa_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
[PATCH 18/18] mtd-cfi_cmdset_0020: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
Re: [PATCH 18/18] mtd-cfi_cmdset_0020: Add some spaces for better code readability Dan Carpenter <dan.carpenter@oracle.com> - 2017-01-12 10:40 +0100
[PATCH 13/18] mtd-cfi_cmdset_0002: Delete an unnecessary variable initialisation in do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
[PATCH 15/18] mtd-cfi_cmdset_0002: Use kcalloc() in cfi_ppb_unlock() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
[PATCH 12/18] mtd-cfi_cmdset_0002: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
Re: [PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-01-11 23:00 +0100
Re: [PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations Marek Vasut <marek.vasut@gmail.com> - 2017-01-11 23:10 +0100
csiph-web