Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1556910
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 05/18] mtd-cfi_cmdset_0001: Use common error handling code in do_write_oneword() |
| Date | 2017-01-11 21:50 +0100 |
| Message-ID | <sYy0h-37v-17@gated-at.bofh.it> (permalink) |
| References | <sYxQC-34a-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Wed, 11 Jan 2017 16:40:47 +0100
Add a jump target so that a bit of exception handling can be better reused
at the end of this function.
Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
drivers/mtd/chips/cfi_cmdset_0001.c | 7 +++----
1 file changed, 3 insertions(+), 4 deletions(-)
diff --git a/drivers/mtd/chips/cfi_cmdset_0001.c b/drivers/mtd/chips/cfi_cmdset_0001.c
index 0c0fa918c9ff..4b134e8beb93 100644
--- a/drivers/mtd/chips/cfi_cmdset_0001.c
+++ b/drivers/mtd/chips/cfi_cmdset_0001.c
@@ -1552,10 +1552,8 @@ static int __xipram do_write_oneword(struct map_info *map, struct flchip *chip,
mutex_lock(&chip->mutex);
ret = get_chip(map, chip, adr, mode);
- if (ret) {
- mutex_unlock(&chip->mutex);
- return ret;
- }
+ if (ret)
+ goto unlock;
XIP_INVAL_CACHED_RANGE(map, adr, map_bankwidth(map));
ENABLE_VPP(map);
@@ -1600,6 +1598,7 @@ static int __xipram do_write_oneword(struct map_info *map, struct flchip *chip,
xip_enable(map, chip, adr);
out: DISABLE_VPP(map);
put_chip(map, chip, adr);
+unlock:
mutex_unlock(&chip->mutex);
return ret;
}
--
2.11.0
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:40 +0100
[PATCH 03/18] mtd-cfi_cmdset_0001: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
Re: [PATCH 03/18] mtd-cfi_cmdset_0001: Add some spaces for better code readability Dan Carpenter <dan.carpenter@oracle.com> - 2017-01-12 10:30 +0100
[PATCH 04/18] mtd-cfi_cmdset_0001: Delete an unnecessary variable initialisation in do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 07/18] mtd-cfi_cmdset_0001: One function call and an unnecessary check less in cfi_intelext_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 05/18] mtd-cfi_cmdset_0001: Use common error handling code in do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 09/18] mtd-cfi_cmdset_0002: Use kmalloc_array() in cfi_amdstd_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 11/18] mtd-cfi_cmdset_0002: Rename a jump label in cfi_amdstd_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 08/18] mtd-cfi_cmdset_0001: Rename a jump label in cfi_intelext_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 10/18] mtd-cfi_cmdset_0002: One function call less in cfi_amdstd_setup() after error detection SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 06/18] mtd-cfi_cmdset_0001: Use kcalloc() in cfi_intelext_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
[PATCH 14/18] mtd-cfi_cmdset_0002: Use common error handling code in do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
[PATCH 16/18] mtd-cfi_cmdset_0020: Use kmalloc_array() in cfi_staa_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
[PATCH 17/18] mtd-cfi_cmdset_0020: Use common error handling code in cfi_staa_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
[PATCH 18/18] mtd-cfi_cmdset_0020: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
Re: [PATCH 18/18] mtd-cfi_cmdset_0020: Add some spaces for better code readability Dan Carpenter <dan.carpenter@oracle.com> - 2017-01-12 10:40 +0100
[PATCH 13/18] mtd-cfi_cmdset_0002: Delete an unnecessary variable initialisation in do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
[PATCH 15/18] mtd-cfi_cmdset_0002: Use kcalloc() in cfi_ppb_unlock() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
[PATCH 12/18] mtd-cfi_cmdset_0002: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
Re: [PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-01-11 23:00 +0100
Re: [PATCH 00/18] MTD-CFI: Fine-tuning for several function implementations Marek Vasut <marek.vasut@gmail.com> - 2017-01-11 23:10 +0100
csiph-web