Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1556921

[PATCH 17/18] mtd-cfi_cmdset_0020: Use common error handling code in cfi_staa_setup()

From SF Markus Elfring <elfring@users.sourceforge.net>
Newsgroups linux.kernel
Subject [PATCH 17/18] mtd-cfi_cmdset_0020: Use common error handling code in cfi_staa_setup()
Date 2017-01-11 22:00 +0100
Message-ID <sYy9Y-3aX-21@gated-at.bofh.it> (permalink)
References <sYxQC-34a-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Markus Elfring <elfring@users.sourceforge.net>
Date: Wed, 11 Jan 2017 20:02:40 +0100

Add jump targets so that a bit of exception handling can be better reused
at the end of this function.

Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
 drivers/mtd/chips/cfi_cmdset_0020.c | 23 ++++++++++-------------
 1 file changed, 10 insertions(+), 13 deletions(-)

diff --git a/drivers/mtd/chips/cfi_cmdset_0020.c b/drivers/mtd/chips/cfi_cmdset_0020.c
index 9cd7b1c6faba..60de9d58dcc6 100644
--- a/drivers/mtd/chips/cfi_cmdset_0020.c
+++ b/drivers/mtd/chips/cfi_cmdset_0020.c
@@ -173,11 +173,8 @@ static struct mtd_info *cfi_staa_setup(struct map_info *map)
 
 	mtd = kzalloc(sizeof(*mtd), GFP_KERNEL);
 	//printk(KERN_DEBUG "number of CFI chips: %d\n", cfi->numchips);
-
-	if (!mtd) {
-		kfree(cfi->cmdset_priv);
-		return NULL;
-	}
+	if (!mtd)
+		goto free_priv;
 
 	mtd->priv = map;
 	mtd->type = MTD_NORFLASH;
@@ -187,11 +184,8 @@ static struct mtd_info *cfi_staa_setup(struct map_info *map)
 	mtd->eraseregions = kmalloc_array(mtd->numeraseregions,
 					  sizeof(*mtd->eraseregions),
 					  GFP_KERNEL);
-	if (!mtd->eraseregions) {
-		kfree(cfi->cmdset_priv);
-		kfree(mtd);
-		return NULL;
-	}
+	if (!mtd->eraseregions)
+		goto free_mtd;
 
 	for (i=0; i<cfi->cfiq->NumEraseRegions; i++) {
 		unsigned long ernum, ersize;
@@ -213,9 +207,7 @@ static struct mtd_info *cfi_staa_setup(struct map_info *map)
 		/* Argh */
 		printk(KERN_WARNING "Sum of regions (%lx) != total size of set of interleaved chips (%lx)\n", offset, devsize);
 		kfree(mtd->eraseregions);
-		kfree(cfi->cmdset_priv);
-		kfree(mtd);
-		return NULL;
+		goto free_mtd;
 	}
 
 	for (i=0; i<mtd->numeraseregions;i++){
@@ -242,6 +234,11 @@ static struct mtd_info *cfi_staa_setup(struct map_info *map)
 	__module_get(THIS_MODULE);
 	mtd->name = map->name;
 	return mtd;
+free_mtd:
+	kfree(mtd);
+free_priv:
+	kfree(cfi->cmdset_priv);
+	return NULL;
 }
 
 
-- 
2.11.0

Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/18] MTD-CFI: Fine-tuning for several function  implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:40 +0100
  [PATCH 03/18] mtd-cfi_cmdset_0001: Add some spaces for better code  readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
    Re: [PATCH 03/18] mtd-cfi_cmdset_0001: Add some spaces for better  code readability Dan Carpenter <dan.carpenter@oracle.com> - 2017-01-12 10:30 +0100
  [PATCH 04/18] mtd-cfi_cmdset_0001: Delete an unnecessary variable  initialisation in do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
  [PATCH 07/18] mtd-cfi_cmdset_0001: One function call and an  unnecessary check less in cfi_intelext_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
  [PATCH 05/18] mtd-cfi_cmdset_0001: Use common error handling code in  do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
  [PATCH 09/18] mtd-cfi_cmdset_0002: Use kmalloc_array() in  cfi_amdstd_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
  [PATCH 11/18] mtd-cfi_cmdset_0002: Rename a jump label in  cfi_amdstd_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
  [PATCH 08/18] mtd-cfi_cmdset_0001: Rename a jump label in  cfi_intelext_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
  [PATCH 10/18] mtd-cfi_cmdset_0002: One function call less in  cfi_amdstd_setup() after error detection SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
  [PATCH 06/18] mtd-cfi_cmdset_0001: Use kcalloc() in  cfi_intelext_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 21:50 +0100
  [PATCH 14/18] mtd-cfi_cmdset_0002: Use common error handling code in  do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
  [PATCH 16/18] mtd-cfi_cmdset_0020: Use kmalloc_array() in  cfi_staa_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
  [PATCH 17/18] mtd-cfi_cmdset_0020: Use common error handling code in  cfi_staa_setup() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
  [PATCH 18/18] mtd-cfi_cmdset_0020: Add some spaces for better code  readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
    Re: [PATCH 18/18] mtd-cfi_cmdset_0020: Add some spaces for better  code readability Dan Carpenter <dan.carpenter@oracle.com> - 2017-01-12 10:40 +0100
  [PATCH 13/18] mtd-cfi_cmdset_0002: Delete an unnecessary variable  initialisation in do_write_oneword() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
  [PATCH 15/18] mtd-cfi_cmdset_0002: Use kcalloc() in cfi_ppb_unlock() SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
  [PATCH 12/18] mtd-cfi_cmdset_0002: Add some spaces for better code  readability SF Markus Elfring <elfring@users.sourceforge.net> - 2017-01-11 22:00 +0100
  Re: [PATCH 00/18] MTD-CFI: Fine-tuning for several function  implementations Boris Brezillon <boris.brezillon@free-electrons.com> - 2017-01-11 23:00 +0100
  Re: [PATCH 00/18] MTD-CFI: Fine-tuning for several function  implementations Marek Vasut <marek.vasut@gmail.com> - 2017-01-11 23:10 +0100

csiph-web