Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1596506
| From | Andrew Lunn <andrew@lunn.ch> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH net-next 10/14] net: dsa: mv88e6xxx: rework port mode setup |
| Date | 2017-03-10 01:30 +0100 |
| Message-ID | <tjgBr-4eD-5@gated-at.bofh.it> (permalink) |
| References | <tjfP3-3Gz-5@gated-at.bofh.it> <tjfP4-3Gz-31@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
Hi Vivien
> +static int mv88e6xxx_set_port_mode_normal(struct mv88e6xxx_chip *chip, int port)
> +{
> + return mv88e6xxx_set_port_mode(chip, port, MV88E6XXX_FRAME_MODE_NORMAL,
> + PORT_CONTROL_EGRESS_UNMODIFIED, 0x9100);
It would be nice to replace this magic number with a #define. How does
the datasheet describe this? 0x9100 is ETH_P_QINQ1. Would that
actually fit?
> +static int mv88e6xxx_setup_port_mode(struct mv88e6xxx_chip *chip, int port)
> +{
> + if (dsa_is_dsa_port(chip->ds, port))
> + return mv88e6xxx_set_port_mode_dsa(chip, port);
> +
> + if (!dsa_is_cpu_port(chip->ds, port))
> + return mv88e6xxx_set_port_mode_normal(chip, port);
Maybe add a dsa_is_normal_port() helper? It just makes the code even
easier to read.
Andrew
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH net-next 00/14] net: dsa: mv88e6xxx: rework ATU support Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
[PATCH net-next 04/14] net: dsa: mv88e6xxx: rework ATU Load/Purge Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
Re: [PATCH net-next 04/14] net: dsa: mv88e6xxx: rework ATU Load/Purge Andrew Lunn <andrew@lunn.ch> - 2017-03-10 03:30 +0100
Re: [PATCH net-next 04/14] net: dsa: mv88e6xxx: rework ATU Load/Purge Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-11 22:00 +0100
Re: [PATCH net-next 04/14] net: dsa: mv88e6xxx: rework ATU Load/Purge Andrew Lunn <andrew@lunn.ch> - 2017-03-12 00:50 +0100
Re: [PATCH net-next 04/14] net: dsa: mv88e6xxx: rework ATU Load/Purge Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-13 16:10 +0100
[PATCH net-next 08/14] net: dsa: mv88e6xxx: rename new FID helper Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
Re: [PATCH net-next 08/14] net: dsa: mv88e6xxx: rename new FID helper Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:20 +0100
[PATCH net-next 05/14] net: dsa: mv88e6xxx: rework ATU GetNext Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
[PATCH net-next 06/14] net: dsa: mv88e6xxx: rework ATU Flush Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
[PATCH net-next 03/14] net: dsa: mv88e6xxx: setup ATU Learn2All Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
Re: [PATCH net-next 03/14] net: dsa: mv88e6xxx: setup ATU Learn2All Andrew Lunn <andrew@lunn.ch> - 2017-03-10 03:10 +0100
Re: [PATCH net-next 03/14] net: dsa: mv88e6xxx: setup ATU Learn2All Andrew Lunn <andrew@lunn.ch> - 2017-03-10 03:10 +0100
[PATCH net-next 14/14] etherdevice: remove unused eth_addr_greater Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
[PATCH net-next 10/14] net: dsa: mv88e6xxx: rework port mode setup Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
Re: [PATCH net-next 10/14] net: dsa: mv88e6xxx: rework port mode setup Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:30 +0100
[PATCH net-next 07/14] net: dsa: mv88e6xxx: rework ATU Remove Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
Re: [PATCH net-next 07/14] net: dsa: mv88e6xxx: rework ATU Remove Andrew Lunn <andrew@lunn.ch> - 2017-03-10 03:40 +0100
[PATCH net-next 12/14] net: dsa: mv88e6xxx: add port ATU learn limit op Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
Re: [PATCH net-next 12/14] net: dsa: mv88e6xxx: add port ATU learn limit op Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:40 +0100
[PATCH net-next 13/14] net: dsa: mv88e6xxx: add port priority override op Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
Re: [PATCH net-next 13/14] net: dsa: mv88e6xxx: add port priority override op Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:40 +0100
[PATCH net-next 09/14] net: dsa: mv88e6xxx: rename the port vector member Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
Re: [PATCH net-next 09/14] net: dsa: mv88e6xxx: rename the port vector member Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:20 +0100
[PATCH net-next 11/14] net: dsa: mv88e6xxx: fix port egress flooding mode Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
[PATCH net-next 02/14] net: dsa: mv88e6xxx: move ATU ageing time setter Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
Re: [PATCH net-next 02/14] net: dsa: mv88e6xxx: move ATU ageing time setter Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:50 +0100
csiph-web