Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1596502

Re: [PATCH net-next 08/14] net: dsa: mv88e6xxx: rename new FID helper

From Andrew Lunn <andrew@lunn.ch>
Newsgroups linux.kernel
Subject Re: [PATCH net-next 08/14] net: dsa: mv88e6xxx: rename new FID helper
Date 2017-03-10 01:20 +0100
Message-ID <tjgrM-4b6-7@gated-at.bofh.it> (permalink)
References <tjfP3-3Gz-5@gated-at.bofh.it> <tjfP3-3Gz-9@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Thu, Mar 09, 2017 at 06:33:18PM -0500, Vivien Didelot wrote:
> Rename the _mv88e6xxx_fid_new helper to mv88e6xxx_atu_new to get rid of
> the old underscore prefix naming convention and be consistent with the
> rest of the chip-wide ATU API.

Hi Vivien

This is the sort of patch i like. Obviously correct, reviewed in a few
seconds.

Reviewed-by: Andrew Lunn <andrew@lunn.ch>

    Andrew


> 
> Signed-off-by: Vivien Didelot <vivien.didelot@savoirfairelinux.com>
> ---
>  drivers/net/dsa/mv88e6xxx/chip.c | 4 ++--
>  1 file changed, 2 insertions(+), 2 deletions(-)
> 
> diff --git a/drivers/net/dsa/mv88e6xxx/chip.c b/drivers/net/dsa/mv88e6xxx/chip.c
> index 72304ca6e5f0..e45c2f3ed654 100644
> --- a/drivers/net/dsa/mv88e6xxx/chip.c
> +++ b/drivers/net/dsa/mv88e6xxx/chip.c
> @@ -1558,7 +1558,7 @@ static int _mv88e6xxx_stu_loadpurge(struct mv88e6xxx_chip *chip,
>  	return _mv88e6xxx_vtu_cmd(chip, GLOBAL_VTU_OP_STU_LOAD_PURGE);
>  }
>  
> -static int _mv88e6xxx_fid_new(struct mv88e6xxx_chip *chip, u16 *fid)
> +static int mv88e6xxx_atu_new(struct mv88e6xxx_chip *chip, u16 *fid)
>  {
>  	DECLARE_BITMAP(fid_bitmap, MV88E6XXX_N_FID);
>  	struct mv88e6xxx_vtu_entry vlan;
> @@ -1612,7 +1612,7 @@ static int _mv88e6xxx_vtu_new(struct mv88e6xxx_chip *chip, u16 vid,
>  	};
>  	int i, err;
>  
> -	err = _mv88e6xxx_fid_new(chip, &vlan.fid);
> +	err = mv88e6xxx_atu_new(chip, &vlan.fid);
>  	if (err)
>  		return err;
>  
> -- 
> 2.12.0
> 

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH net-next 00/14] net: dsa: mv88e6xxx: rework ATU support Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
  [PATCH net-next 04/14] net: dsa: mv88e6xxx: rework ATU Load/Purge Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
    Re: [PATCH net-next 04/14] net: dsa: mv88e6xxx: rework ATU Load/Purge Andrew Lunn <andrew@lunn.ch> - 2017-03-10 03:30 +0100
      Re: [PATCH net-next 04/14] net: dsa: mv88e6xxx: rework ATU Load/Purge Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-11 22:00 +0100
        Re: [PATCH net-next 04/14] net: dsa: mv88e6xxx: rework ATU Load/Purge Andrew Lunn <andrew@lunn.ch> - 2017-03-12 00:50 +0100
          Re: [PATCH net-next 04/14] net: dsa: mv88e6xxx: rework ATU Load/Purge Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-13 16:10 +0100
  [PATCH net-next 08/14] net: dsa: mv88e6xxx: rename new FID helper Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
    Re: [PATCH net-next 08/14] net: dsa: mv88e6xxx: rename new FID helper Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:20 +0100
  [PATCH net-next 05/14] net: dsa: mv88e6xxx: rework ATU GetNext Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
  [PATCH net-next 06/14] net: dsa: mv88e6xxx: rework ATU Flush Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
  [PATCH net-next 03/14] net: dsa: mv88e6xxx: setup ATU Learn2All Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
    Re: [PATCH net-next 03/14] net: dsa: mv88e6xxx: setup ATU Learn2All Andrew Lunn <andrew@lunn.ch> - 2017-03-10 03:10 +0100
    Re: [PATCH net-next 03/14] net: dsa: mv88e6xxx: setup ATU Learn2All Andrew Lunn <andrew@lunn.ch> - 2017-03-10 03:10 +0100
  [PATCH net-next 14/14] etherdevice: remove unused eth_addr_greater Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
  [PATCH net-next 10/14] net: dsa: mv88e6xxx: rework port mode setup Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
    Re: [PATCH net-next 10/14] net: dsa: mv88e6xxx: rework port mode  setup Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:30 +0100
  [PATCH net-next 07/14] net: dsa: mv88e6xxx: rework ATU Remove Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
    Re: [PATCH net-next 07/14] net: dsa: mv88e6xxx: rework ATU Remove Andrew Lunn <andrew@lunn.ch> - 2017-03-10 03:40 +0100
  [PATCH net-next 12/14] net: dsa: mv88e6xxx: add port ATU learn limit op Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
    Re: [PATCH net-next 12/14] net: dsa: mv88e6xxx: add port ATU learn  limit op Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:40 +0100
  [PATCH net-next 13/14] net: dsa: mv88e6xxx: add port priority override op Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
    Re: [PATCH net-next 13/14] net: dsa: mv88e6xxx: add port priority  override op Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:40 +0100
  [PATCH net-next 09/14] net: dsa: mv88e6xxx: rename the port vector member Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
    Re: [PATCH net-next 09/14] net: dsa: mv88e6xxx: rename the port  vector member Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:20 +0100
  [PATCH net-next 11/14] net: dsa: mv88e6xxx: fix port egress flooding mode Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
  [PATCH net-next 02/14] net: dsa: mv88e6xxx: move ATU ageing time setter Vivien Didelot <vivien.didelot@savoirfairelinux.com> - 2017-03-10 00:40 +0100
    Re: [PATCH net-next 02/14] net: dsa: mv88e6xxx: move ATU ageing time  setter Andrew Lunn <andrew@lunn.ch> - 2017-03-10 01:50 +0100

csiph-web