Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1269867

[PATCH 0/7] some small improvement

From Yaowei Bai <baiyaowei@cmss.chinamobile.com>
Newsgroups linux.kernel
Subject [PATCH 0/7] some small improvement
Date 2015-11-16 08:00 +0100
Message-ID <qvlVD-3Sn-3@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


This patchset only performs some small improvement to mm. First, make
several functions return bool to improve readability, and then remove
unused is_unevictable_lru function and refactor memmap_valid_within
for simplicity.

No functional change.

Yaowei Bai (7):
  ipc/shm: is_file_shm_hugepages can be boolean
  mm/hugetlb: is_file_hugepages can be boolean
  mm/memblock: memblock_is_memory/reserved can be boolean
  mm/vmscan: page_is_file_cache can be boolean
  mm/lru: remove unused is_unevictable_lru function
  mm/gfp: make gfp_zonelist return directly and bool
  mm/mmzone: refactor memmap_valid_within

 include/linux/gfp.h       |  7 ++-----
 include/linux/hugetlb.h   | 10 ++++------
 include/linux/memblock.h  |  4 ++--
 include/linux/mm_inline.h |  6 +++---
 include/linux/mmzone.h    | 11 +++--------
 include/linux/shm.h       |  6 +++---
 ipc/shm.c                 |  2 +-
 mm/memblock.c             |  4 ++--
 mm/mmzone.c               | 10 ++--------
 9 files changed, 22 insertions(+), 38 deletions(-)

-- 
1.9.1



--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at  http://vger.kernel.org/majordomo-info.html
Please read the FAQ at  http://www.tux.org/lkml/

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH 0/7] some small improvement Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-16 08:00 +0100
  [PATCH 4/7] mm/vmscan: page_is_file_cache can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-16 08:00 +0100
    Re: [PATCH 4/7] mm/vmscan: page_is_file_cache can be boolean David Rientjes <rientjes@google.com> - 2015-11-16 11:20 +0100
      Re: [PATCH 4/7] mm/vmscan: page_is_file_cache can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-17 03:20 +0100
  [PATCH 6/7] mm/gfp: make gfp_zonelist return directly and bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-16 08:00 +0100
    Re: [PATCH 6/7] mm/gfp: make gfp_zonelist return directly and bool David Rientjes <rientjes@google.com> - 2015-11-16 11:10 +0100
      Re: [PATCH 6/7] mm/gfp: make gfp_zonelist return directly and bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-17 03:10 +0100
        Re: [PATCH 6/7] mm/gfp: make gfp_zonelist return directly and bool David Rientjes <rientjes@google.com> - 2015-11-17 06:50 +0100
          Re: [PATCH 6/7] mm/gfp: make gfp_zonelist return directly and bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-17 09:40 +0100
  [PATCH] mm/zonelist: enumerate zonelists array index Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-17 10:10 +0100
  [PATCH] mm/mmzone: memmap_valid_within can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-18 02:40 +0100

csiph-web