Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1269868
| From | Yaowei Bai <baiyaowei@cmss.chinamobile.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 4/7] mm/vmscan: page_is_file_cache can be boolean |
| Date | 2015-11-16 08:00 +0100 |
| Message-ID | <qvlVE-3Sn-21@gated-at.bofh.it> (permalink) |
| References | <qvlVD-3Sn-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
This patch makes page_is_file_cache return bool to improve
readability due to this particular function only using either
one or zero as its return value.
No functional change.
Signed-off-by: Yaowei Bai <baiyaowei@cmss.chinamobile.com>
---
include/linux/mm_inline.h | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/include/linux/mm_inline.h b/include/linux/mm_inline.h
index cf55945..af73135 100644
--- a/include/linux/mm_inline.h
+++ b/include/linux/mm_inline.h
@@ -8,8 +8,8 @@
* page_is_file_cache - should the page be on a file LRU or anon LRU?
* @page: the page to test
*
- * Returns 1 if @page is page cache page backed by a regular filesystem,
- * or 0 if @page is anonymous, tmpfs or otherwise ram or swap backed.
+ * Returns true if @page is page cache page backed by a regular filesystem,
+ * or false if @page is anonymous, tmpfs or otherwise ram or swap backed.
* Used by functions that manipulate the LRU lists, to sort a page
* onto the right LRU list.
*
@@ -17,7 +17,7 @@
* needs to survive until the page is last deleted from the LRU, which
* could be as far down as __page_cache_release.
*/
-static inline int page_is_file_cache(struct page *page)
+static inline bool page_is_file_cache(struct page *page)
{
return !PageSwapBacked(page);
}
--
1.9.1
--
To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
the body of a message to majordomo@vger.kernel.org
More majordomo info at http://vger.kernel.org/majordomo-info.html
Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 0/7] some small improvement Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-16 08:00 +0100
[PATCH 4/7] mm/vmscan: page_is_file_cache can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-16 08:00 +0100
Re: [PATCH 4/7] mm/vmscan: page_is_file_cache can be boolean David Rientjes <rientjes@google.com> - 2015-11-16 11:20 +0100
Re: [PATCH 4/7] mm/vmscan: page_is_file_cache can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-17 03:20 +0100
[PATCH 6/7] mm/gfp: make gfp_zonelist return directly and bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-16 08:00 +0100
Re: [PATCH 6/7] mm/gfp: make gfp_zonelist return directly and bool David Rientjes <rientjes@google.com> - 2015-11-16 11:10 +0100
Re: [PATCH 6/7] mm/gfp: make gfp_zonelist return directly and bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-17 03:10 +0100
Re: [PATCH 6/7] mm/gfp: make gfp_zonelist return directly and bool David Rientjes <rientjes@google.com> - 2015-11-17 06:50 +0100
Re: [PATCH 6/7] mm/gfp: make gfp_zonelist return directly and bool Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-17 09:40 +0100
[PATCH] mm/zonelist: enumerate zonelists array index Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-17 10:10 +0100
[PATCH] mm/mmzone: memmap_valid_within can be boolean Yaowei Bai <baiyaowei@cmss.chinamobile.com> - 2015-11-18 02:40 +0100
csiph-web