Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1614389
| From | Joe Perches <joe@perches.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning |
| Date | 2017-04-01 06:00 +0200 |
| Message-ID | <trimJ-5Fi-1@gated-at.bofh.it> (permalink) |
| References | <trguC-4hQ-5@gated-at.bofh.it> <trguC-4hQ-9@gated-at.bofh.it> <tri3o-5wb-3@gated-at.bofh.it> <tri3o-5wb-13@gated-at.bofh.it> <trid3-5zE-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Sat, 2017-04-01 at 04:46 +0100, Al Viro wrote: > On Fri, Mar 31, 2017 at 08:36:22PM -0700, Joe Perches wrote: > > On Sat, 2017-04-01 at 04:32 +0100, Al Viro wrote: > > > On Fri, Mar 31, 2017 at 06:59:19PM -0700, Chewie Lin wrote: > > > > Replace string with formatted arguments in the dev_warn() call. It removes > > > > the checkpatch warning: > > > > > > > > WARNING: Prefer using "%s", __func__ to embedded function names > > > > [] > > > Again, checkpatch warning is badly written > > > > In your opinion, what wording would be better? > > MILD SUGGESTION: don't spell the function name out in format strings; > "this_function: foo is %d", n > might be better off as > "%s: foo is %d", __func__, n > in case you ever move it to another function or rename your function. Thank you sir, may I have another. checkpatch messages are single line.
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH] eudyptula challenge Chewie Lin <linsh@oregonstate.edu> - 2017-04-01 04:00 +0200
[PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Chewie Lin <linsh@oregonstate.edu> - 2017-04-01 04:00 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Joe Perches <joe@perches.com> - 2017-04-01 04:20 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Randy Dunlap <rdunlap@infradead.org> - 2017-04-01 04:20 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Joe Perches <joe@perches.com> - 2017-04-01 04:50 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Chewie Lin <linsh@oregonstate.edu> - 2017-04-01 05:20 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Joe Perches <joe@perches.com> - 2017-04-01 05:40 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Al Viro <viro@ZenIV.linux.org.uk> - 2017-04-01 05:40 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Joe Perches <joe@perches.com> - 2017-04-01 05:40 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Al Viro <viro@ZenIV.linux.org.uk> - 2017-04-01 05:50 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Joe Perches <joe@perches.com> - 2017-04-01 06:00 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Al Viro <viro@ZenIV.linux.org.uk> - 2017-04-01 06:10 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Joe Perches <joe@perches.com> - 2017-04-01 06:30 +0200
Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Chewie Lin <linsh@oregonstate.edu> - 2017-04-01 06:40 +0200
csiph-web