Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1614392

Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning

From Joe Perches <joe@perches.com>
Newsgroups linux.kernel
Subject Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning
Date 2017-04-01 06:30 +0200
Message-ID <triPL-67y-1@gated-at.bofh.it> (permalink)
References (2 earlier) <tri3o-5wb-3@gated-at.bofh.it> <tri3o-5wb-13@gated-at.bofh.it> <trid3-5zE-1@gated-at.bofh.it> <trimJ-5Fi-1@gated-at.bofh.it> <triwq-5Y9-5@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On Sat, 2017-04-01 at 05:08 +0100, Al Viro wrote:
> On Fri, Mar 31, 2017 at 08:52:50PM -0700, Joe Perches wrote:
> 
> > > MILD SUGGESTION: don't spell the function name out in format strings;
> > > 	"this_function: foo is %d", n
> > > might be better off as
> > > 	"%s: foo is %d", __func__, n
> > > in case you ever move it to another function or rename your function.
> > 
> > Thank you sir, may I have another.
> > 
> > checkpatch messages are single line.
> 
> Too bad... Incidentally, being able to get more detailed explanation of
> a warning might be a serious improvement, especially if it contains
> the rationale.  Hell, something like TeX handling of errors might be
> a good idea - warning printed, offered actions include 'give more help',
> 'continue', 'exit', 'from now on suppress this kind of warning', 'from
> now on just dump this kind of warning into log and keep going', 'from
> now on dump all warnings into log and keep going'.

Well, there is the possibility to have longer messages.
It's just the --terse option has to be somewhat sensible.

> And yes, I'm serious about having something like "mild suggestion" as
> possible severity - people are using that thing to look for potential
> improvements to make and 'such and such change might be useful for such
> and such reasons' is a lot more useful than 'this needs to be thus because
> it must be thus or I'll keep warning'.

I agree about checkpatch and ERROR/WARNING/CHECK vs some other wording.

https://lkml.org/lkml/2016/8/27/180
https://lkml.org/lkml/2015/7/16/568

The other thing that might help is for people to take
the warnings the script produces less seriously.

Maybe convert:

ERROR -> defect
WARNING -> unstylish
CHECK -> nitpick

or some such.

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH] eudyptula challenge Chewie Lin <linsh@oregonstate.edu> - 2017-04-01 04:00 +0200
  [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch warning Chewie Lin <linsh@oregonstate.edu> - 2017-04-01 04:00 +0200
    Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Joe Perches <joe@perches.com> - 2017-04-01 04:20 +0200
    Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Randy Dunlap <rdunlap@infradead.org> - 2017-04-01 04:20 +0200
      Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Joe Perches <joe@perches.com> - 2017-04-01 04:50 +0200
        Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Chewie Lin <linsh@oregonstate.edu> - 2017-04-01 05:20 +0200
          Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Joe Perches <joe@perches.com> - 2017-04-01 05:40 +0200
    Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Al Viro <viro@ZenIV.linux.org.uk> - 2017-04-01 05:40 +0200
      Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Joe Perches <joe@perches.com> - 2017-04-01 05:40 +0200
        Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Al Viro <viro@ZenIV.linux.org.uk> - 2017-04-01 05:50 +0200
          Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Joe Perches <joe@perches.com> - 2017-04-01 06:00 +0200
            Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Al Viro <viro@ZenIV.linux.org.uk> - 2017-04-01 06:10 +0200
              Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Joe Perches <joe@perches.com> - 2017-04-01 06:30 +0200
      Re: [PATCH 001/001] drivers/staging/vt6656/main_usb.c: checkpatch  warning Chewie Lin <linsh@oregonstate.edu> - 2017-04-01 06:40 +0200

csiph-web