Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1475627
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 12/17] s390/debug: Use memdup_user() rather than duplicating its implementation |
| Date | 2016-09-03 14:40 +0200 |
| Message-ID | <sdioN-58V-21@gated-at.bofh.it> (permalink) |
| References | <qEuGl-43C-5@gated-at.bofh.it> <sdhVL-4Vr-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Fri, 2 Sep 2016 08:45:26 +0200
Reuse existing functionality from memdup_user() instead of keeping
duplicate source code.
Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
arch/s390/kernel/debug.c | 10 +++-------
1 file changed, 3 insertions(+), 7 deletions(-)
diff --git a/arch/s390/kernel/debug.c b/arch/s390/kernel/debug.c
index 4a12faf..a9fcf72 100644
--- a/arch/s390/kernel/debug.c
+++ b/arch/s390/kernel/debug.c
@@ -1162,13 +1162,9 @@ debug_get_user_string(const char __user *user_buf, size_t user_len)
{
char* buffer;
- buffer = kmalloc(user_len + 1, GFP_KERNEL);
- if (!buffer)
- return ERR_PTR(-ENOMEM);
- if (copy_from_user(buffer, user_buf, user_len) != 0) {
- kfree(buffer);
- return ERR_PTR(-EFAULT);
- }
+ buffer = memdup_user(user_buf, user_len + 1);
+ if (IS_ERR(buffer))
+ return PTR_ERR(buffer);
/* got the string, now strip linefeed. */
if (buffer[user_len - 1] == '\n')
buffer[user_len - 1] = 0;
--
2.9.3
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/17] s390/debug: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:10 +0200
[PATCH 01/17] s390/debug: Use kmalloc_array() in debug_areas_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 04/17] s390/debug: Rename jump labels in debug_areas_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 02/17] s390/debug: Delete unnecessary braces SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 05/17] s390/debug: Fix jump targets in debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 06/17] s390/debug: Rename jump labels in debug_info_copy() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 07/17] s390/debug: Rename jump labels in debug_open() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 10/17] s390/debug: Delete an unnecessary initialisation in debug_prolog_level_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 08/17] s390/debug: Fix a jump target in debug_register_mode() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 09/17] s390/debug: Return directly if a null pointer was passed to debug_unregister() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
Re: [PATCH 09/17] s390/debug: Return directly if a null pointer was passed to debug_unregister() walter harms <wharms@bfs.de> - 2016-09-03 14:50 +0200
[PATCH 11/17] s390/debug: Fix indentation in 13 functions SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 03/17] s390/debug: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 16/17] s390/debug: Improve determination of sizes in debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 13/17] s390/debug: Improve a size determination in debug_open() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 14/17] s390/debug: Improve a size determination in debug_sprintf_format_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 12/17] s390/debug: Use memdup_user() rather than duplicating its implementation SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 17/17] s390/debug: Improve another size determination in debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:50 +0200
[PATCH 15/17] s390/debug: Improve a size determination in debug_raw_header_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:50 +0200
Re: [PATCH 00/17] s390/debug: Fine-tuning for several function implementations Martin Schwidefsky <schwidefsky@de.ibm.com> - 2016-09-05 12:40 +0200
Re: s390/debug: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-05 12:50 +0200
csiph-web