Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1475603
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 00/17] s390/debug: Fine-tuning for several function implementations |
| Date | 2016-09-03 14:10 +0200 |
| Message-ID | <sdhVL-4Vr-3@gated-at.bofh.it> (permalink) |
| References | <qEuGl-43C-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Markus Elfring <elfring@users.sourceforge.net> Date: Sat, 3 Sep 2016 13:54:32 +0200 Several update suggestions were taken into account from static source code analysis. Markus Elfring (17): Use kmalloc_array() in debug_areas_alloc() Delete unnecessary braces Add some spaces for better code readability Rename jump labels in debug_areas_alloc() Fix jump targets in debug_info_alloc() Rename jump labels in debug_info_copy() Rename jump labels in debug_open() Fix a jump target in debug_register_mode() Return directly if a null pointer was passed to debug_unregister() Delete an unnecessary initialisation in debug_prolog_level_fn() Fix indentation in 13 functions Use memdup_user() rather than duplicating its implementation Improve a size determination in debug_open() Improve a size determination in debug_sprintf_format_fn() Improve a size determination in debug_raw_header_fn() Improve determination of sizes in debug_info_alloc() Improve another size determination in debug_info_alloc() arch/s390/kernel/debug.c | 433 ++++++++++++++++++++++------------------------- 1 file changed, 204 insertions(+), 229 deletions(-) -- 2.9.3
Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread
[PATCH 00/17] s390/debug: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:10 +0200
[PATCH 01/17] s390/debug: Use kmalloc_array() in debug_areas_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 04/17] s390/debug: Rename jump labels in debug_areas_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 02/17] s390/debug: Delete unnecessary braces SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 05/17] s390/debug: Fix jump targets in debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 06/17] s390/debug: Rename jump labels in debug_info_copy() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 07/17] s390/debug: Rename jump labels in debug_open() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 10/17] s390/debug: Delete an unnecessary initialisation in debug_prolog_level_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 08/17] s390/debug: Fix a jump target in debug_register_mode() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 09/17] s390/debug: Return directly if a null pointer was passed to debug_unregister() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
Re: [PATCH 09/17] s390/debug: Return directly if a null pointer was passed to debug_unregister() walter harms <wharms@bfs.de> - 2016-09-03 14:50 +0200
[PATCH 11/17] s390/debug: Fix indentation in 13 functions SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 03/17] s390/debug: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 16/17] s390/debug: Improve determination of sizes in debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 13/17] s390/debug: Improve a size determination in debug_open() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 14/17] s390/debug: Improve a size determination in debug_sprintf_format_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 12/17] s390/debug: Use memdup_user() rather than duplicating its implementation SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 17/17] s390/debug: Improve another size determination in debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:50 +0200
[PATCH 15/17] s390/debug: Improve a size determination in debug_raw_header_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:50 +0200
Re: [PATCH 00/17] s390/debug: Fine-tuning for several function implementations Martin Schwidefsky <schwidefsky@de.ibm.com> - 2016-09-05 12:40 +0200
Re: s390/debug: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-05 12:50 +0200
csiph-web