Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1475624

[PATCH 13/17] s390/debug: Improve a size determination in debug_open()

From SF Markus Elfring <elfring@users.sourceforge.net>
Newsgroups linux.kernel
Subject [PATCH 13/17] s390/debug: Improve a size determination in debug_open()
Date 2016-09-03 14:40 +0200
Message-ID <sdioN-58V-15@gated-at.bofh.it> (permalink)
References <qEuGl-43C-5@gated-at.bofh.it> <sdhVL-4Vr-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Markus Elfring <elfring@users.sourceforge.net>
Date: Fri, 2 Sep 2016 09:02:22 +0200

* Replace the specification of a data type by a pointer dereference
  as the parameter for the operator "sizeof" to make the corresponding size
  determination a bit safer according to the Linux coding style convention.

* Improve source code layout for one function call.

Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
 arch/s390/kernel/debug.c | 3 +--
 1 file changed, 1 insertion(+), 2 deletions(-)

diff --git a/arch/s390/kernel/debug.c b/arch/s390/kernel/debug.c
index a9fcf72..32ceb5e 100644
--- a/arch/s390/kernel/debug.c
+++ b/arch/s390/kernel/debug.c
@@ -636,8 +636,7 @@ debug_open(struct inode *inode, struct file *file)
 		rc = -ENOMEM;
 		goto unlock;
 	}
-	p_info = kmalloc(sizeof(file_private_info_t),
-						GFP_KERNEL);
+	p_info = kmalloc(sizeof(*p_info), GFP_KERNEL);
 	if (!p_info) {
 		debug_info_free(debug_info_snapshot);
 		rc = -ENOMEM;
-- 
2.9.3

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[PATCH 00/17] s390/debug: Fine-tuning for several function  implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:10 +0200
  [PATCH 01/17] s390/debug: Use kmalloc_array() in debug_areas_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
  [PATCH 04/17] s390/debug: Rename jump labels in debug_areas_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
  [PATCH 02/17] s390/debug: Delete unnecessary braces SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
  [PATCH 05/17] s390/debug: Fix jump targets in debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
  [PATCH 06/17] s390/debug: Rename jump labels in debug_info_copy() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
  [PATCH 07/17] s390/debug: Rename jump labels in debug_open() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
  [PATCH 10/17] s390/debug: Delete an unnecessary initialisation in  debug_prolog_level_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
  [PATCH 08/17] s390/debug: Fix a jump target in debug_register_mode() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
  [PATCH 09/17] s390/debug: Return directly if a null pointer was  passed to debug_unregister() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
    Re: [PATCH 09/17] s390/debug: Return directly if a null pointer was  passed to debug_unregister() walter harms <wharms@bfs.de> - 2016-09-03 14:50 +0200
  [PATCH 11/17] s390/debug: Fix indentation in 13 functions SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
  [PATCH 03/17] s390/debug: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
  [PATCH 16/17] s390/debug: Improve determination of sizes in  debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
  [PATCH 13/17] s390/debug: Improve a size determination in  debug_open() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
  [PATCH 14/17] s390/debug: Improve a size determination in  debug_sprintf_format_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
  [PATCH 12/17] s390/debug: Use memdup_user() rather than duplicating  its implementation SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
  [PATCH 17/17] s390/debug: Improve another size determination in  debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:50 +0200
  [PATCH 15/17] s390/debug: Improve a size determination in  debug_raw_header_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:50 +0200
  Re: [PATCH 00/17] s390/debug: Fine-tuning for several function  implementations Martin Schwidefsky <schwidefsky@de.ibm.com> - 2016-09-05 12:40 +0200
    Re: s390/debug: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-05 12:50 +0200

csiph-web