Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1475611
| From | SF Markus Elfring <elfring@users.sourceforge.net> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH 07/17] s390/debug: Rename jump labels in debug_open() |
| Date | 2016-09-03 14:30 +0200 |
| Message-ID | <sdif7-55W-1@gated-at.bofh.it> (permalink) |
| References | <qEuGl-43C-5@gated-at.bofh.it> <sdhVL-4Vr-3@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
From: Markus Elfring <elfring@users.sourceforge.net>
Date: Thu, 1 Sep 2016 18:44:17 +0200
Adjust jump labels according to the current Linux coding style convention.
Signed-off-by: Markus Elfring <elfring@users.sourceforge.net>
---
arch/s390/kernel/debug.c | 14 ++++++--------
1 file changed, 6 insertions(+), 8 deletions(-)
diff --git a/arch/s390/kernel/debug.c b/arch/s390/kernel/debug.c
index 1f32578..1cce76a 100644
--- a/arch/s390/kernel/debug.c
+++ b/arch/s390/kernel/debug.c
@@ -614,15 +614,13 @@ debug_open(struct inode *inode, struct file *file)
continue;
else if (debug_info->debugfs_entries[i] ==
file->f_path.dentry) {
- goto found; /* found view ! */
+ goto copy_info;
}
}
/* no entry found */
rc = -EINVAL;
- goto out;
-
-found:
-
+ goto unlock;
+ copy_info:
/* Make snapshot of current debug areas to get it consistent. */
/* To copy all the areas is only needed, if we have a view which */
/* formats the debug areas. */
@@ -636,14 +634,14 @@ found:
if (!debug_info_snapshot) {
rc = -ENOMEM;
- goto out;
+ goto unlock;
}
p_info = kmalloc(sizeof(file_private_info_t),
GFP_KERNEL);
if (!p_info) {
debug_info_free(debug_info_snapshot);
rc = -ENOMEM;
- goto out;
+ goto unlock;
}
p_info->offset = 0;
p_info->debug_info_snap = debug_info_snapshot;
@@ -656,7 +654,7 @@ found:
file->private_data = p_info;
debug_info_get(debug_info);
nonseekable_open(inode, file);
-out:
+ unlock:
mutex_unlock(&debug_mutex);
return rc;
}
--
2.9.3
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH 00/17] s390/debug: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:10 +0200
[PATCH 01/17] s390/debug: Use kmalloc_array() in debug_areas_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 04/17] s390/debug: Rename jump labels in debug_areas_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 02/17] s390/debug: Delete unnecessary braces SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 05/17] s390/debug: Fix jump targets in debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:20 +0200
[PATCH 06/17] s390/debug: Rename jump labels in debug_info_copy() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 07/17] s390/debug: Rename jump labels in debug_open() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 10/17] s390/debug: Delete an unnecessary initialisation in debug_prolog_level_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 08/17] s390/debug: Fix a jump target in debug_register_mode() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 09/17] s390/debug: Return directly if a null pointer was passed to debug_unregister() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
Re: [PATCH 09/17] s390/debug: Return directly if a null pointer was passed to debug_unregister() walter harms <wharms@bfs.de> - 2016-09-03 14:50 +0200
[PATCH 11/17] s390/debug: Fix indentation in 13 functions SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 03/17] s390/debug: Add some spaces for better code readability SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:30 +0200
[PATCH 16/17] s390/debug: Improve determination of sizes in debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 13/17] s390/debug: Improve a size determination in debug_open() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 14/17] s390/debug: Improve a size determination in debug_sprintf_format_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 12/17] s390/debug: Use memdup_user() rather than duplicating its implementation SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:40 +0200
[PATCH 17/17] s390/debug: Improve another size determination in debug_info_alloc() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:50 +0200
[PATCH 15/17] s390/debug: Improve a size determination in debug_raw_header_fn() SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-03 14:50 +0200
Re: [PATCH 00/17] s390/debug: Fine-tuning for several function implementations Martin Schwidefsky <schwidefsky@de.ibm.com> - 2016-09-05 12:40 +0200
Re: s390/debug: Fine-tuning for several function implementations SF Markus Elfring <elfring@users.sourceforge.net> - 2016-09-05 12:50 +0200
csiph-web