Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1329903

[PATCH v4 0/4] Fix ordering of ftrace/livepatch calls on module load and unload

From Jessica Yu <jeyu@redhat.com>
Newsgroups linux.kernel
Subject [PATCH v4 0/4] Fix ordering of ftrace/livepatch calls on module load and unload
Date 2016-02-09 06:00 +0100
Message-ID <r08z8-7uB-1@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


As explained here [1], livepatch modules are failing to initialize properly
because the ftrace coming module notifier (which calls
ftrace_module_enable()) runs *after* the livepatch module notifier (which
enables the patch(es)). Thus livepatch attempts to apply patches to
modules before ftrace_module_enable() is even called for the corresponding
module(s). As a result, patch modules break. Ftrace code must run before
livepatch on module load, and the reverse is true on module unload.

For ftrace and livepatch, order of initialization (plus exit/cleanup code) is
important for loading and unloading modules, and using module notifiers to
perform this work is not ideal since it is not always clear what gets called
when. In this patchset, dependence on the module notifier call chain is removed
in favor of hard coding the corresponding function calls in the module loader.
This promotes better code visibility and ensures that ftrace and livepatch code
get called in the correct order on patch module load and unload.

Tested the changes with a test livepatch module that patches 9p and nilfs2,
and verified that the issue described in [1] is fixed.

Patches are based on linux-next.

v1:
https://lkml.kernel.org/g/1454049827-3726-1-git-send-email-jeyu@redhat.com
v2:
https://lkml.kernel.org/g/1454375856-27757-1-git-send-email-jeyu@redhat.com
v3:
https://lkml.kernel.org/g/1454728097-7106-1-git-send-email-jeyu@redhat.com

v4:
- Split part of complete_formation() into prepare_coming_module() to make
  error handling a bit easier
- Minor tweak: change mod->state to going before calling going notifiers in
  the load_module error path
- Swapped out obj->mod = NULL assignment in klp_module_coming() for a
  call to klp_free_object_loaded()

v3:
- Fix incorrect comments
- Rename klp_module_{enable,disable} to klp_module_{coming,going}
- Remove externs from livepatch.h
- Fix error handling in kernel/module.c

v2:
- Instead of splitting the ftrace and livepatch notifiers into coming + going
  notifiers and adjusting their priorities, remove ftrace and livepatch notifiers
  completely and hard-code the necessary function calls in the module loader.

[1] http://lkml.kernel.org/g/20160128204033.GA32131@packer-debian-8-amd64.digitalocean.com

Jessica Yu (4):
  modules: split part of complete_formation() into
    prepare_coming_module()
  modules: set mod->state to MODULE_STATE_GOING before going notifiers
    are called
  ftrace/module: remove ftrace module notifier
  livepatch/module: remove livepatch module notifier

 include/linux/ftrace.h    |   6 +-
 include/linux/livepatch.h |   9 +++
 kernel/livepatch/core.c   | 145 ++++++++++++++++++++++------------------------
 kernel/module.c           |  40 ++++++++++---
 kernel/trace/ftrace.c     |  36 +-----------
 5 files changed, 116 insertions(+), 120 deletions(-)

-- 
2.4.3

Back to linux.kernel | Previous | Next — Next in thread | Find similar | Unroll thread


Thread

[PATCH v4 0/4] Fix ordering of ftrace/livepatch calls on module load and unload Jessica Yu <jeyu@redhat.com> - 2016-02-09 06:00 +0100
  [PATCH v4 1/4] modules: split part of complete_formation() into prepare_coming_module() Jessica Yu <jeyu@redhat.com> - 2016-02-09 06:00 +0100
    Re: [PATCH v4 1/4] modules: split part of complete_formation() into  prepare_coming_module() Josh Poimboeuf <jpoimboe@redhat.com> - 2016-02-09 16:50 +0100
    Re: [PATCH v4 1/4] modules: split part of complete_formation() into  prepare_coming_module() Miroslav Benes <mbenes@suse.cz> - 2016-02-10 11:20 +0100
    Re: [PATCH v4 1/4] modules: split part of complete_formation() into  prepare_coming_module() Petr Mladek <pmladek@suse.com> - 2016-02-10 13:20 +0100
  [PATCH v4 2/4] modules: set mod->state to MODULE_STATE_GOING before going notifiers are called Jessica Yu <jeyu@redhat.com> - 2016-02-09 06:00 +0100
    Re: [PATCH v4 2/4] modules: set mod->state to MODULE_STATE_GOING  before going notifiers are called Josh Poimboeuf <jpoimboe@redhat.com> - 2016-02-09 16:50 +0100
    Re: [PATCH v4 2/4] modules: set mod->state to MODULE_STATE_GOING  before going notifiers are called Petr Mladek <pmladek@suse.com> - 2016-02-10 13:40 +0100
  [PATCH v4 3/4] ftrace/module: remove ftrace module notifier Jessica Yu <jeyu@redhat.com> - 2016-02-09 06:00 +0100
    Re: [PATCH v4 3/4] ftrace/module: remove ftrace module notifier Josh Poimboeuf <jpoimboe@redhat.com> - 2016-02-09 16:50 +0100
    Re: [PATCH v4 3/4] ftrace/module: remove ftrace module notifier Miroslav Benes <mbenes@suse.cz> - 2016-02-10 11:30 +0100
  [PATCH v4 4/4] livepatch/module: remove livepatch module notifier Jessica Yu <jeyu@redhat.com> - 2016-02-09 06:00 +0100
    Re: [PATCH v4 4/4] livepatch/module: remove livepatch module notifier Josh Poimboeuf <jpoimboe@redhat.com> - 2016-02-09 16:50 +0100
    Re: [PATCH v4 4/4] livepatch/module: remove livepatch module notifier Rusty Russell <rusty@rustcorp.com.au> - 2016-02-10 01:30 +0100
      Re: [PATCH v4 4/4] livepatch/module: remove livepatch module  notifier Jiri Kosina <jikos@kernel.org> - 2016-02-10 11:30 +0100
        Re: [PATCH v4 4/4] livepatch/module: remove livepatch module  notifier Jiri Kosina <jikos@kernel.org> - 2016-02-15 00:40 +0100
          Re: [PATCH v4 4/4] livepatch/module: remove livepatch module notifier Josh Poimboeuf <jpoimboe@redhat.com> - 2016-02-16 00:30 +0100
            Re: [PATCH v4 4/4] livepatch/module: remove livepatch module  notifier Jiri Kosina <jikos@kernel.org> - 2016-02-16 00:50 +0100
              Re: livepatch/module: remove livepatch module notifier Jessica Yu <jeyu@redhat.com> - 2016-02-16 01:50 +0100
                Re: livepatch/module: remove livepatch module notifier Miroslav Benes <mbenes@suse.cz> - 2016-02-16 09:50 +0100
                Re: livepatch/module: remove livepatch module notifier Jessica Yu <jeyu@redhat.com> - 2016-02-16 21:00 +0100

csiph-web