Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1314526

Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers

From "H. Peter Anvin" <hpa@zytor.com>
Newsgroups linux.kernel
Subject Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers
Date 2016-01-21 22:10 +0100
Message-ID <qTuEq-2ry-7@gated-at.bofh.it> (permalink)
References <qTlhM-4qv-7@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


On 01/21/16 03:02, Huaitong Han wrote:
> v2:add a commit message.
> 
> Most of magic numbers of x86_capability have been converted to enum
> cpuid_leafs, and this patch does update the remaining part.
> 
> Signed-off-by: Huaitong Han <huaitong.han@intel.com>

Also, the plural of leaf is "leaves".

	-hpa

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Huaitong Han <huaitong.han@intel.com> - 2016-01-21 12:10 +0100
  Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 12:50 +0100
    Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:10 +0100
      Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 22:30 +0100
        Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:30 +0100
          Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:40 +0100
            Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 22:50 +0100
              Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 23:00 +0100
          Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 22:40 +0100
  Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:10 +0100

csiph-web