Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1314542
| From | "H. Peter Anvin" <hpa@zytor.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers |
| Date | 2016-01-21 22:30 +0100 |
| Message-ID | <qTuXM-2zU-11@gated-at.bofh.it> (permalink) |
| References | <qTlhM-4qv-7@gated-at.bofh.it> <qTlUt-4G5-7@gated-at.bofh.it> <qTuEq-2ry-19@gated-at.bofh.it> <qTuXL-2zU-1@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 01/21/16 13:21, Borislav Petkov wrote: > On Thu, Jan 21, 2016 at 01:04:57PM -0800, H. Peter Anvin wrote: >> I'm wondering, though, if it wouldn't be better to turn these into >> macros so that they can be used in assembly code. That way the >> definitions can be interspersed with the X86_FEATURE_ definitions, >> too. > > What concrete use case do you have in mind, i.e., example? > See X86_CAPABILITY in head_32.S for example. -hpa
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Huaitong Han <huaitong.han@intel.com> - 2016-01-21 12:10 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 12:50 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:10 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 22:30 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:30 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:40 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 22:50 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 23:00 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 22:40 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:10 +0100
csiph-web