Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1314529
| From | "H. Peter Anvin" <hpa@zytor.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers |
| Date | 2016-01-21 22:10 +0100 |
| Message-ID | <qTuEq-2ry-19@gated-at.bofh.it> (permalink) |
| References | <qTlhM-4qv-7@gated-at.bofh.it> <qTlUt-4G5-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 01/21/16 03:42, Borislav Petkov wrote: > On Thu, Jan 21, 2016 at 07:02:40PM +0800, Huaitong Han wrote: >> v2:add a commit message. >> >> Most of magic numbers of x86_capability have been converted to enum >> cpuid_leafs, and this patch does update the remaining part. >> >> Signed-off-by: Huaitong Han <huaitong.han@intel.com> >> --- >> arch/x86/include/asm/elf.h | 2 +- >> arch/x86/kernel/mpparse.c | 2 +- >> arch/x86/lguest/boot.c | 2 +- >> arch/x86/xen/enlighten.c | 2 +- >> 4 files changed, 4 insertions(+), 4 deletions(-) > I'm wondering, though, if it wouldn't be better to turn these into macros so that they can be used in assembly code. That way the definitions can be interspersed with the X86_FEATURE_ definitions, too. -hpa
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Huaitong Han <huaitong.han@intel.com> - 2016-01-21 12:10 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 12:50 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:10 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 22:30 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:30 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:40 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 22:50 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 23:00 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers Borislav Petkov <bp@alien8.de> - 2016-01-21 22:40 +0100
Re: [PATCH V2] x86: use enum cpuid_leafs instead of magic numbers "H. Peter Anvin" <hpa@zytor.com> - 2016-01-21 22:10 +0100
csiph-web