Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.debian.maint.python > #9236 > unrolled thread

Naming convention for -doc package

Started byGhislain Vaillant <ghisvail@gmail.com>
First post2017-02-09 21:40 +0100
Last post2017-02-15 22:40 +0100
Articles 10 — 5 participants

Back to article view | Back to linux.debian.maint.python


Contents

  Naming convention for -doc package Ghislain Vaillant <ghisvail@gmail.com> - 2017-02-09 21:40 +0100
    Re: Naming convention for -doc package Sandro Tosi <morph@debian.org> - 2017-02-09 23:00 +0100
      Re: Naming convention for -doc package Ghislain Vaillant <ghisvail@gmail.com> - 2017-02-10 00:00 +0100
        Re: Naming convention for -doc package Sandro Tosi <morph@debian.org> - 2017-02-10 01:00 +0100
          Re: Naming convention for -doc package Ghislain Vaillant <ghisvail@gmail.com> - 2017-02-10 11:00 +0100
            Re: Naming convention for -doc package Sandro Tosi <morph@debian.org> - 2017-02-10 14:50 +0100
    Re: Naming convention for -doc package Piotr Ożarowski <piotr@debian.org> - 2017-02-10 10:10 +0100
      Re: Re: Naming convention for -doc package Ghislain Vaillant <ghisvail@gmail.com> - 2017-02-10 22:30 +0100
        Re: Naming convention for -doc package Ben Finney <bignose@debian.org> - 2017-02-11 03:00 +0100
          Re: Naming convention for -doc package Christopher Hoskin <christopher.hoskin@gmail.com> - 2017-02-15 22:40 +0100

#9236 — Naming convention for -doc package

FromGhislain Vaillant <ghisvail@gmail.com>
Date2017-02-09 21:40 +0100
SubjectNaming convention for -doc package
Message-ID<t93Fw-2mP-17@gated-at.bofh.it>
Just to get the opinion from the team,

Now that new packages are targeting the Buster cycle, and that Python 2
packages should no longer be built, how should the corresponding -doc
packages be named?

For instance, I have a source package (pytest-qt) which builds a Python
3 binary package and its corresponding documentation. Right now, they
are respectively named python3-pytest-qt and pytest-qt-doc.

Shall we keep the current python- prefix (as per Python the language,
not Python 2 the version), use a python3- prefix, or drop the prefix
(as I temporarily did)?

Thought I'd better ask than be sorry later.

Cheers,
Ghis

[toc] | [next] | [standalone]


#9237

FromSandro Tosi <morph@debian.org>
Date2017-02-09 23:00 +0100
Message-ID<t94UV-33U-15@gated-at.bofh.it>
In reply to#9236
On Thu, Feb 9, 2017 at 3:17 PM, Ghislain Vaillant <ghisvail@gmail.com> wrote:
> Now that new packages are targeting the Buster cycle, and that Python 2
> packages should no longer be built,

this is news to me, can you point me to where this was announced?

-- 
Sandro "morph" Tosi
My website: http://sandrotosi.me/
Me at Debian: http://wiki.debian.org/SandroTosi
G+: https://plus.google.com/u/0/+SandroTosi

[toc] | [prev] | [next] | [standalone]


#9238

FromGhislain Vaillant <ghisvail@gmail.com>
Date2017-02-10 00:00 +0100
Message-ID<t95QZ-3Gl-3@gated-at.bofh.it>
In reply to#9237
On Thu, 2017-02-09 at 16:51 -0500, Sandro Tosi wrote:
> On Thu, Feb 9, 2017 at 3:17 PM, Ghislain Vaillant <ghisvail@gmail.com> wrote:
> > Now that new packages are targeting the Buster cycle, and that Python 2
> > packages should no longer be built,
> 
> this is news to me, can you point me to where this was announced?

Announced, I don't know. But:

https://lintian.debian.org/tags/new-package-should-not-package-python2-module.html

Unless I am missing something?

[toc] | [prev] | [next] | [standalone]


#9239

FromSandro Tosi <morph@debian.org>
Date2017-02-10 01:00 +0100
Message-ID<t96N3-4gQ-7@gated-at.bofh.it>
In reply to#9238
On Thu, Feb 9, 2017 at 5:40 PM, Ghislain Vaillant <ghisvail@gmail.com> wrote:
> On Thu, 2017-02-09 at 16:51 -0500, Sandro Tosi wrote:
>> On Thu, Feb 9, 2017 at 3:17 PM, Ghislain Vaillant <ghisvail@gmail.com> wrote:
>> > Now that new packages are targeting the Buster cycle, and that Python 2
>> > packages should no longer be built,
>>
>> this is news to me, can you point me to where this was announced?
>
> Announced, I don't know. But:
>
> https://lintian.debian.org/tags/new-package-should-not-package-python2-module.html
>
> Unless I am missing something?

this was triggered by
https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=829744 -- sigh



-- 
Sandro "morph" Tosi
My website: http://sandrotosi.me/
Me at Debian: http://wiki.debian.org/SandroTosi
G+: https://plus.google.com/u/0/+SandroTosi

[toc] | [prev] | [next] | [standalone]


#9244

FromGhislain Vaillant <ghisvail@gmail.com>
Date2017-02-10 11:00 +0100
Message-ID<t9g9I-1L2-3@gated-at.bofh.it>
In reply to#9239
On Thu, 2017-02-09 at 18:58 -0500, Sandro Tosi wrote:
> On Thu, Feb 9, 2017 at 5:40 PM, Ghislain Vaillant <ghisvail@gmail.com> wrote:
> > On Thu, 2017-02-09 at 16:51 -0500, Sandro Tosi wrote:
> > > On Thu, Feb 9, 2017 at 3:17 PM, Ghislain Vaillant <ghisvail@gmail.com> wrote:
> > > > Now that new packages are targeting the Buster cycle, and that Python 2
> > > > packages should no longer be built,
> > > 
> > > this is news to me, can you point me to where this was announced?
> > 
> > Announced, I don't know. But:
> > 
> > https://lintian.debian.org/tags/new-package-should-not-package-python2-module.html
> > 
> > Unless I am missing something?
> 
> this was triggered by
> https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=829744 -- sigh

Thanks for finding it out. So based on #829744, both pytest-qt and
pytest-xvfb, which are new packages, do not produce a corresponding
Python 2 binary package.

Back to the original question, what about the naming for -doc packages?

Ghis

[toc] | [prev] | [next] | [standalone]


#9248

FromSandro Tosi <morph@debian.org>
Date2017-02-10 14:50 +0100
Message-ID<t9jKh-41W-3@gated-at.bofh.it>
In reply to#9244
On Fri, Feb 10, 2017 at 4:33 AM, Ghislain Vaillant <ghisvail@gmail.com> wrote:
> So based on #829744, both pytest-qt and
> pytest-xvfb, which are new packages, do not produce a corresponding
> Python 2 binary package.

my point is: this looks wrong and premature, and should have been
discussed more broadly and not just lamby submitting a bug report to
lintian, and thus getting it already kind-of-official

-- 
Sandro "morph" Tosi
My website: http://sandrotosi.me/
Me at Debian: http://wiki.debian.org/SandroTosi
G+: https://plus.google.com/u/0/+SandroTosi

[toc] | [prev] | [next] | [standalone]


#9243

FromPiotr Ożarowski <piotr@debian.org>
Date2017-02-10 10:10 +0100
Message-ID<t9fnj-1qo-3@gated-at.bofh.it>
In reply to#9236
> For instance, I have a source package (pytest-qt) which builds a Python
> 3 binary package and its corresponding documentation. Right now, they
> are respectively named python3-pytest-qt and pytest-qt-doc.

I'd use python-modulename-doc even for new packages that provide
python3-modulename binary package only

BTW, it's pytestqt, not pytest-qt so binary package name for Python 3
should be python3-pytestqt (source name: pytest-qt)

> Shall we keep the current python- prefix (as per Python the language,
> not Python 2 the version)

that would be my pick
-- 
Piotr Ożarowski                         Debian GNU/Linux Developer
www.ozarowski.pl          www.griffith.cc           www.debian.org
GPG Fingerprint: 1D2F A898 58DA AF62 1786 2DF7 AEF6 F1A2 A745 7645

[toc] | [prev] | [next] | [standalone]


#9249

FromGhislain Vaillant <ghisvail@gmail.com>
Date2017-02-10 22:30 +0100
Message-ID<t9qVr-nT-5@gated-at.bofh.it>
In reply to#9243
[Piotr Ożarowski]
> > For instance, I have a source package (pytest-qt) which builds a Python
> > 3 binary package and its corresponding documentation. Right now, they
> > are respectively named python3-pytest-qt and pytest-qt-doc.
> 
> I'd use python-modulename-doc even for new packages that provide
> python3-modulename binary package only

Ok.

> BTW, it's pytestqt, not pytest-qt so binary package name for Python 3
> should be python3-pytestqt (source name: pytest-qt)

Considering pytest plugins aren't meant to be used directly, but by
pytest via the registered entry-point, using "pytestqt" over "pytest-
qt" for the binary package sounded unnecessary to me.

And yes, I do know there is a policy and I follow it closely. In this
particular case however, we would be breaking the consistency between
the naming of the other pytest plugins for no obvious benefit to me.

> > Shall we keep the current python- prefix (as per Python the language,
> > not Python 2 the version)
> 
> that would be my pick

So given your criteria above, you would choose:

- python3-pytestqt
- python-pytestqt-doc

Am I correct?

Is everyone happy with that?

Cheers,
Ghis

[toc] | [prev] | [next] | [standalone]


#9251

FromBen Finney <bignose@debian.org>
Date2017-02-11 03:00 +0100
Message-ID<t9v8J-2Px-3@gated-at.bofh.it>
In reply to#9249
Ghislain Vaillant <ghisvail@gmail.com> writes:

> So given your criteria above, you would choose:
>
> - python3-pytestqt
> - python-pytestqt-doc
>
> Am I correct?

That allows a future ‘python4-pytestqt’ to use the same documentation.

So far, the overwhelming pattern is that upstream's documentation does
not come in separate versions for different Python platforms. It's the
same Py.test QT documentation, regardless of Python version.

The corresponding Debian packages of documentation should not be named
by any Python version, either.

> Is everyone happy with that?

I am.

-- 
 \         “Smoking cures weight problems. Eventually.” —Steven Wright |
  `\                                                                   |
_o__)                                                                  |
Ben Finney <bignose@debian.org>

[toc] | [prev] | [next] | [standalone]


#9268

FromChristopher Hoskin <christopher.hoskin@gmail.com>
Date2017-02-15 22:40 +0100
Message-ID<tbfsS-5g5-21@gated-at.bofh.it>
In reply to#9251

[Multipart message — attachments visible in raw view] — view raw

Currently lintian is applying the
new-package-should-not-package-python2-module tag to documentation packages
as well.

I've filed a bug report with a patch:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=855243

Christopher Hoskin

On 11 February 2017 at 01:51, Ben Finney <bignose@debian.org> wrote:

> Ghislain Vaillant <ghisvail@gmail.com> writes:
>
> > So given your criteria above, you would choose:
> >
> > - python3-pytestqt
> > - python-pytestqt-doc
> >
> > Am I correct?
>
> That allows a future ‘python4-pytestqt’ to use the same documentation.
>
> So far, the overwhelming pattern is that upstream's documentation does
> not come in separate versions for different Python platforms. It's the
> same Py.test QT documentation, regardless of Python version.
>
> The corresponding Debian packages of documentation should not be named
> by any Python version, either.
>
> > Is everyone happy with that?
>
> I am.
>
> --
>  \         “Smoking cures weight problems. Eventually.” —Steven Wright |
>   `\                                                                   |
> _o__)                                                                  |
> Ben Finney <bignose@debian.org>
>
>

[toc] | [prev] | [standalone]


Back to top | Article view | linux.debian.maint.python


csiph-web