Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1665780

[PATCH 14/23] clocksource/drivers: Rename CLOCKSOURCE_ACPI_DECLARE to TIMER_ACPI_DECLARE

From Daniel Lezcano <daniel.lezcano@linaro.org>
Newsgroups linux.kernel
Subject [PATCH 14/23] clocksource/drivers: Rename CLOCKSOURCE_ACPI_DECLARE to TIMER_ACPI_DECLARE
Date 2017-06-14 14:50 +0200
Message-ID <tSfUf-5dU-43@gated-at.bofh.it> (permalink)
References <tSfKy-5an-33@gated-at.bofh.it> <tSfUd-5dU-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


The macro name is now renamed to 'TIMER_ACPI_DECLARE' for consistency
with the CLOCKSOURCE_OF_DECLARE => TIMER_OF_DECLARE change.

Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
Reviewed-by: Linus Walleij <linus.walleij@linaro.org>
---
 drivers/clocksource/arm_arch_timer.c | 2 +-
 include/linux/clocksource.h          | 2 +-
 2 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/clocksource/arm_arch_timer.c b/drivers/clocksource/arm_arch_timer.c
index bc60cd7..a89d41c 100644
--- a/drivers/clocksource/arm_arch_timer.c
+++ b/drivers/clocksource/arm_arch_timer.c
@@ -1516,5 +1516,5 @@ static int __init arch_timer_acpi_init(struct acpi_table_header *table)
 
 	return arch_timer_common_init();
 }
-CLOCKSOURCE_ACPI_DECLARE(arch_timer, ACPI_SIG_GTDT, arch_timer_acpi_init);
+TIMER_ACPI_DECLARE(arch_timer, ACPI_SIG_GTDT, arch_timer_acpi_init);
 #endif
diff --git a/include/linux/clocksource.h b/include/linux/clocksource.h
index 010bb9f..e43f37f 100644
--- a/include/linux/clocksource.h
+++ b/include/linux/clocksource.h
@@ -258,7 +258,7 @@ extern void timer_probe(void);
 static inline void timer_probe(void) {}
 #endif
 
-#define CLOCKSOURCE_ACPI_DECLARE(name, table_id, fn)		\
+#define TIMER_ACPI_DECLARE(name, table_id, fn)		\
 	ACPI_DECLARE_PROBE_ENTRY(clksrc, name, table_id, 0, NULL, 0, fn)
 
 #endif /* _LINUX_CLOCKSOURCE_H */
-- 
2.7.4

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[GIT PULL] clockevents for 4.13 Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:40 +0200
  [PATCH 02/23] clocksource/drivers/fttmr010: Fix the clock handling Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 09/23] clocksource/drivers/fttmr010: Add AST2500 compatible string Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 16/23] clocksource/drivers: Rename CLKSRC_OF to TIMER_OF Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 03/23] clocksource/drivers/fttmr010: Merge FTTMR010 DT bindings Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 01/23] arm: aspeed: Add clock-names property to timer node Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 11/23] Revert "clockevents: Add a clkevt-of mechanism like clksrc-of" Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 05/23] clocksource/drivers/fttmr010: Use state container Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 19/23] clocksource/drivers/fttmr010: Optimize sched_clock() Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 06/23] clocksource/drivers/fttmr010: Switch to use bitops Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 07/23] clocksource/drivers/fttmr010: Switch to use TIMER2 src Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 08/23] clocksource/drivers/fttmr010: Merge Moxa into FTTMR010 Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 10/23] clocksource/drivers/fttmr010: Fix aspeed-2500 initialization Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 17/23] clocksource/drivers: Rename CLKSRC_ACPI to TIMER_ACPI Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 14/23] clocksource/drivers: Rename CLOCKSOURCE_ACPI_DECLARE to TIMER_ACPI_DECLARE Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 18/23] clocksource/drivers: Add an alias macro CLOCKSOURCE_OF_DECLARE Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 15/23] clocksource/drivers: Rename clksrc table to timer Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 04/23] clocksource/drivers/fttmr010: Drop Gemini specifics Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 20/23] clocksource/drivers/tcb_clksrc: Save timer context on suspend/resume Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 21/23] clocksource/drivers: Add timer-of common init routine Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 22/23] clocksource/drivers/fttmr010: Implement delay timer Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 23/23] clocksource/drivers/fttmr010: Factor out clock read code Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200

csiph-web