Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1665763

[PATCH 03/23] clocksource/drivers/fttmr010: Merge FTTMR010 DT bindings

From Daniel Lezcano <daniel.lezcano@linaro.org>
Newsgroups linux.kernel
Subject [PATCH 03/23] clocksource/drivers/fttmr010: Merge FTTMR010 DT bindings
Date 2017-06-14 14:50 +0200
Message-ID <tSfUd-5dU-13@gated-at.bofh.it> (permalink)
References <tSfKy-5an-33@gated-at.bofh.it> <tSfUd-5dU-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Linus Walleij <linus.walleij@linaro.org>

This merges the Moxa and FTTMR010 device tree bindings into the
Faraday binding document to avoid confusion.

The FTTMR010 is the IP block used by these SoCs, in vanilla
or modified variant.

The Aspeed variant is modified such that it is no longer fully
register-compatible with FTTMR010 so for this reason it is not
listed with two compatible strings, instead just one.

Cc: Joel Stanley <joel@jms.id.au>
Tested-by: Jonas Jensen <jonas.jensen@gmail.com>
Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
Acked-by: Rob Herring <robh@kernel.org>
Acked-by: Joel Stanley <joel@jms.id.au>
Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
---
 .../devicetree/bindings/timer/faraday,fttmr010.txt    |  4 +++-
 .../devicetree/bindings/timer/moxa,moxart-timer.txt   | 19 -------------------
 2 files changed, 3 insertions(+), 20 deletions(-)
 delete mode 100644 Documentation/devicetree/bindings/timer/moxa,moxart-timer.txt

diff --git a/Documentation/devicetree/bindings/timer/faraday,fttmr010.txt b/Documentation/devicetree/bindings/timer/faraday,fttmr010.txt
index b73ca6c..6e18bd6 100644
--- a/Documentation/devicetree/bindings/timer/faraday,fttmr010.txt
+++ b/Documentation/devicetree/bindings/timer/faraday,fttmr010.txt
@@ -7,7 +7,9 @@ Required properties:
 
 - compatible : Must be one of
   "faraday,fttmr010"
-  "cortina,gemini-timer"
+  "cortina,gemini-timer", "faraday,fttmr010"
+  "moxa,moxart-timer", "faraday,fttmr010"
+  "aspeed,ast2400-timer"
 - reg : Should contain registers location and length
 - interrupts : Should contain the three timer interrupts usually with
   flags for falling edge
diff --git a/Documentation/devicetree/bindings/timer/moxa,moxart-timer.txt b/Documentation/devicetree/bindings/timer/moxa,moxart-timer.txt
deleted file mode 100644
index e207c11..0000000
--- a/Documentation/devicetree/bindings/timer/moxa,moxart-timer.txt
+++ /dev/null
@@ -1,19 +0,0 @@
-MOXA ART timer
-
-Required properties:
-
-- compatible : Must be one of:
- 	- "moxa,moxart-timer"
- 	- "aspeed,ast2400-timer"
-- reg : Should contain registers location and length
-- interrupts : Should contain the timer interrupt number
-- clocks : Should contain phandle for the clock that drives the counter
-
-Example:
-
-	timer: timer@98400000 {
-		compatible = "moxa,moxart-timer";
-		reg = <0x98400000 0x42>;
-		interrupts = <19 1>;
-		clocks = <&coreclk>;
-	};
-- 
2.7.4

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[GIT PULL] clockevents for 4.13 Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:40 +0200
  [PATCH 02/23] clocksource/drivers/fttmr010: Fix the clock handling Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 09/23] clocksource/drivers/fttmr010: Add AST2500 compatible string Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 16/23] clocksource/drivers: Rename CLKSRC_OF to TIMER_OF Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 03/23] clocksource/drivers/fttmr010: Merge FTTMR010 DT bindings Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 01/23] arm: aspeed: Add clock-names property to timer node Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 11/23] Revert "clockevents: Add a clkevt-of mechanism like clksrc-of" Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 05/23] clocksource/drivers/fttmr010: Use state container Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 19/23] clocksource/drivers/fttmr010: Optimize sched_clock() Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 06/23] clocksource/drivers/fttmr010: Switch to use bitops Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 07/23] clocksource/drivers/fttmr010: Switch to use TIMER2 src Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 08/23] clocksource/drivers/fttmr010: Merge Moxa into FTTMR010 Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 10/23] clocksource/drivers/fttmr010: Fix aspeed-2500 initialization Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 17/23] clocksource/drivers: Rename CLKSRC_ACPI to TIMER_ACPI Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 14/23] clocksource/drivers: Rename CLOCKSOURCE_ACPI_DECLARE to TIMER_ACPI_DECLARE Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 18/23] clocksource/drivers: Add an alias macro CLOCKSOURCE_OF_DECLARE Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 15/23] clocksource/drivers: Rename clksrc table to timer Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 04/23] clocksource/drivers/fttmr010: Drop Gemini specifics Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 20/23] clocksource/drivers/tcb_clksrc: Save timer context on suspend/resume Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 21/23] clocksource/drivers: Add timer-of common init routine Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 22/23] clocksource/drivers/fttmr010: Implement delay timer Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 23/23] clocksource/drivers/fttmr010: Factor out clock read code Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200

csiph-web