Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1665772

[PATCH 06/23] clocksource/drivers/fttmr010: Switch to use bitops

From Daniel Lezcano <daniel.lezcano@linaro.org>
Newsgroups linux.kernel
Subject [PATCH 06/23] clocksource/drivers/fttmr010: Switch to use bitops
Date 2017-06-14 14:50 +0200
Message-ID <tSfUe-5dU-33@gated-at.bofh.it> (permalink)
References <tSfKy-5an-33@gated-at.bofh.it> <tSfUd-5dU-3@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


From: Linus Walleij <linus.walleij@linaro.org>

This switches the drivers to use the bitops BIT() macro
to define bits.

Cc: Joel Stanley <joel@jms.id.au>
Tested-by: Jonas Jensen <jonas.jensen@gmail.com>
Signed-off-by: Linus Walleij <linus.walleij@linaro.org>
Signed-off-by: Daniel Lezcano <daniel.lezcano@linaro.org>
---
 drivers/clocksource/timer-fttmr010.c | 43 ++++++++++++++++++------------------
 1 file changed, 22 insertions(+), 21 deletions(-)

diff --git a/drivers/clocksource/timer-fttmr010.c b/drivers/clocksource/timer-fttmr010.c
index 9ad3148..9df14cf 100644
--- a/drivers/clocksource/timer-fttmr010.c
+++ b/drivers/clocksource/timer-fttmr010.c
@@ -16,6 +16,7 @@
 #include <linux/sched_clock.h>
 #include <linux/clk.h>
 #include <linux/slab.h>
+#include <linux/bitops.h>
 
 /*
  * Register definitions for the timers
@@ -36,31 +37,31 @@
 #define TIMER_INTR_STATE	(0x34)
 #define TIMER_INTR_MASK		(0x38)
 
-#define TIMER_1_CR_ENABLE	(1 << 0)
-#define TIMER_1_CR_CLOCK	(1 << 1)
-#define TIMER_1_CR_INT		(1 << 2)
-#define TIMER_2_CR_ENABLE	(1 << 3)
-#define TIMER_2_CR_CLOCK	(1 << 4)
-#define TIMER_2_CR_INT		(1 << 5)
-#define TIMER_3_CR_ENABLE	(1 << 6)
-#define TIMER_3_CR_CLOCK	(1 << 7)
-#define TIMER_3_CR_INT		(1 << 8)
-#define TIMER_1_CR_UPDOWN	(1 << 9)
-#define TIMER_2_CR_UPDOWN	(1 << 10)
-#define TIMER_3_CR_UPDOWN	(1 << 11)
+#define TIMER_1_CR_ENABLE	BIT(0)
+#define TIMER_1_CR_CLOCK	BIT(1)
+#define TIMER_1_CR_INT		BIT(2)
+#define TIMER_2_CR_ENABLE	BIT(3)
+#define TIMER_2_CR_CLOCK	BIT(4)
+#define TIMER_2_CR_INT		BIT(5)
+#define TIMER_3_CR_ENABLE	BIT(6)
+#define TIMER_3_CR_CLOCK	BIT(7)
+#define TIMER_3_CR_INT		BIT(8)
+#define TIMER_1_CR_UPDOWN	BIT(9)
+#define TIMER_2_CR_UPDOWN	BIT(10)
+#define TIMER_3_CR_UPDOWN	BIT(11)
 #define TIMER_DEFAULT_FLAGS	(TIMER_1_CR_UPDOWN | \
 				 TIMER_3_CR_ENABLE | \
 				 TIMER_3_CR_UPDOWN)
 
-#define TIMER_1_INT_MATCH1	(1 << 0)
-#define TIMER_1_INT_MATCH2	(1 << 1)
-#define TIMER_1_INT_OVERFLOW	(1 << 2)
-#define TIMER_2_INT_MATCH1	(1 << 3)
-#define TIMER_2_INT_MATCH2	(1 << 4)
-#define TIMER_2_INT_OVERFLOW	(1 << 5)
-#define TIMER_3_INT_MATCH1	(1 << 6)
-#define TIMER_3_INT_MATCH2	(1 << 7)
-#define TIMER_3_INT_OVERFLOW	(1 << 8)
+#define TIMER_1_INT_MATCH1	BIT(0)
+#define TIMER_1_INT_MATCH2	BIT(1)
+#define TIMER_1_INT_OVERFLOW	BIT(2)
+#define TIMER_2_INT_MATCH1	BIT(3)
+#define TIMER_2_INT_MATCH2	BIT(4)
+#define TIMER_2_INT_OVERFLOW	BIT(5)
+#define TIMER_3_INT_MATCH1	BIT(6)
+#define TIMER_3_INT_MATCH2	BIT(7)
+#define TIMER_3_INT_OVERFLOW	BIT(8)
 #define TIMER_INT_ALL_MASK	0x1ff
 
 struct fttmr010 {
-- 
2.7.4

Back to linux.kernel | Previous | NextPrevious in thread | Next in thread | Find similar | Unroll thread


Thread

[GIT PULL] clockevents for 4.13 Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:40 +0200
  [PATCH 02/23] clocksource/drivers/fttmr010: Fix the clock handling Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 09/23] clocksource/drivers/fttmr010: Add AST2500 compatible string Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 16/23] clocksource/drivers: Rename CLKSRC_OF to TIMER_OF Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 03/23] clocksource/drivers/fttmr010: Merge FTTMR010 DT bindings Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
  [PATCH 01/23] arm: aspeed: Add clock-names property to timer node Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 11/23] Revert "clockevents: Add a clkevt-of mechanism like clksrc-of" Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 05/23] clocksource/drivers/fttmr010: Use state container Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 19/23] clocksource/drivers/fttmr010: Optimize sched_clock() Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 06/23] clocksource/drivers/fttmr010: Switch to use bitops Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 07/23] clocksource/drivers/fttmr010: Switch to use TIMER2 src Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 08/23] clocksource/drivers/fttmr010: Merge Moxa into FTTMR010 Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 10/23] clocksource/drivers/fttmr010: Fix aspeed-2500 initialization Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 17/23] clocksource/drivers: Rename CLKSRC_ACPI to TIMER_ACPI Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 14/23] clocksource/drivers: Rename CLOCKSOURCE_ACPI_DECLARE to TIMER_ACPI_DECLARE Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 18/23] clocksource/drivers: Add an alias macro CLOCKSOURCE_OF_DECLARE Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 15/23] clocksource/drivers: Rename clksrc table to timer Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 04/23] clocksource/drivers/fttmr010: Drop Gemini specifics Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 20/23] clocksource/drivers/tcb_clksrc: Save timer context on suspend/resume Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 21/23] clocksource/drivers: Add timer-of common init routine Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 22/23] clocksource/drivers/fttmr010: Implement delay timer Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200
    [PATCH 23/23] clocksource/drivers/fttmr010: Factor out clock read code Daniel Lezcano <daniel.lezcano@linaro.org> - 2017-06-14 14:50 +0200

csiph-web