Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1437480

Re: [PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface

From Ganesh Mahendran <opensource.ganesh@gmail.com>
Newsgroups linux.kernel
Subject Re: [PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface
Date 2016-07-06 08:30 +0200
Message-ID <rROvn-5Cf-19@gated-at.bofh.it> (permalink)
References <rR61j-2jM-3@gated-at.bofh.it> <rRKUO-3fr-19@gated-at.bofh.it>
Organization linux.* mail to news gateway

Show all headers | View raw


2016-07-06 10:32 GMT+08:00 Minchan Kim <minchan@kernel.org>:
> Hi Ganesh,
>
> On Mon, Jul 04, 2016 at 02:49:52PM +0800, Ganesh Mahendran wrote:
>> This patch changes trace_zsmalloc_compact_start[end] to
>> trace_zs_compact_start[end] to keep function naming consistent
>> with others in zsmalloc
>>
>> Also this patch remove pages_total_compacted information which
>> may not really needed.
>>
>> Signed-off-by: Ganesh Mahendran <opensource.ganesh@gmail.com>
>
> Once we decide to add event trace, I prefer getting more detailed
> information which is hard to get it via /sys/block/zram/.
> So, we can add trace __zs_compact as well as zs_compact with
> some changes.
>
> IOW,
>
> zs_compact
>         trace_zs_compact_start(pool->name)
>         __zs_compact
>                 trace_zs_compact(class, scanned_obj, freed_pages)
>         trace_zs_compact_end(pool->name)

Thanks, I will do it.

Back to linux.kernel | Previous | NextPrevious in thread | Find similar | Unroll thread


Thread

[PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
  [PATCH v2 4/8] mm/zsmalloc: use class->objs_per_zspage to get num of max objects Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
  [PATCH v2 6/8] mm/zsmalloc: keep comments consistent with code Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
    Re: [PATCH v2 6/8] mm/zsmalloc: keep comments consistent with code Minchan Kim <minchan@kernel.org> - 2016-07-06 04:50 +0200
  [PATCH v2 5/8] mm/zsmalloc: avoid calculate max objects of zspage twice Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
    Re: [PATCH v2 5/8] mm/zsmalloc: avoid calculate max objects of  zspage twice Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2016-07-05 03:20 +0200
    Re: [PATCH v2 5/8] mm/zsmalloc: avoid calculate max objects of  zspage twice Minchan Kim <minchan@kernel.org> - 2016-07-06 04:50 +0200
  [PATCH v2 8/8] mm/zsmalloc: use helper to clear page->flags bit Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
    Re: [PATCH v2 8/8] mm/zsmalloc: use helper to clear page->flags bit Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2016-07-04 10:50 +0200
  [PATCH v2 2/8] mm/zsmalloc: use obj_index to keep consistent with others Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
    Re: [PATCH v2 2/8] mm/zsmalloc: use obj_index to keep consistent  with others Minchan Kim <minchan@kernel.org> - 2016-07-06 04:40 +0200
  [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
    Re: [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2016-07-04 10:50 +0200
      Re: [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 11:30 +0200
        Re: [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2016-07-05 03:10 +0200
          Re: [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Minchan Kim <minchan@kernel.org> - 2016-07-06 04:50 +0200
            Re: [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-06 08:30 +0200
  Re: [PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface Steven Rostedt <rostedt@goodmis.org> - 2016-07-05 19:00 +0200
  Re: [PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface Minchan Kim <minchan@kernel.org> - 2016-07-06 04:40 +0200
    Re: [PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-06 08:30 +0200

csiph-web