Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]


Groups > linux.kernel > #1436132

[PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface

From Ganesh Mahendran <opensource.ganesh@gmail.com>
Newsgroups linux.kernel
Subject [PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface
Date 2016-07-04 09:00 +0200
Message-ID <rR61j-2jM-3@gated-at.bofh.it> (permalink)
Organization linux.* mail to news gateway

Show all headers | View raw


This patch changes trace_zsmalloc_compact_start[end] to
trace_zs_compact_start[end] to keep function naming consistent
with others in zsmalloc

Also this patch remove pages_total_compacted information which
may not really needed.

Signed-off-by: Ganesh Mahendran <opensource.ganesh@gmail.com>
---
v2: change commit message
---
 include/trace/events/zsmalloc.h | 16 ++++++----------
 mm/zsmalloc.c                   |  7 +++----
 2 files changed, 9 insertions(+), 14 deletions(-)

diff --git a/include/trace/events/zsmalloc.h b/include/trace/events/zsmalloc.h
index 3b6f14e..c7a39f4 100644
--- a/include/trace/events/zsmalloc.h
+++ b/include/trace/events/zsmalloc.h
@@ -7,7 +7,7 @@
 #include <linux/types.h>
 #include <linux/tracepoint.h>
 
-TRACE_EVENT(zsmalloc_compact_start,
+TRACE_EVENT(zs_compact_start,
 
 	TP_PROTO(const char *pool_name),
 
@@ -25,29 +25,25 @@ TRACE_EVENT(zsmalloc_compact_start,
 		  __entry->pool_name)
 );
 
-TRACE_EVENT(zsmalloc_compact_end,
+TRACE_EVENT(zs_compact_end,
 
-	TP_PROTO(const char *pool_name, unsigned long pages_compacted,
-			unsigned long pages_total_compacted),
+	TP_PROTO(const char *pool_name, unsigned long pages_compacted),
 
-	TP_ARGS(pool_name, pages_compacted, pages_total_compacted),
+	TP_ARGS(pool_name, pages_compacted),
 
 	TP_STRUCT__entry(
 		__field(const char *, pool_name)
 		__field(unsigned long, pages_compacted)
-		__field(unsigned long, pages_total_compacted)
 	),
 
 	TP_fast_assign(
 		__entry->pool_name = pool_name;
 		__entry->pages_compacted = pages_compacted;
-		__entry->pages_total_compacted = pages_total_compacted;
 	),
 
-	TP_printk("pool %s: %ld pages compacted(total %ld)",
+	TP_printk("pool %s: %ld pages compacted",
 		  __entry->pool_name,
-		  __entry->pages_compacted,
-		  __entry->pages_total_compacted)
+		  __entry->pages_compacted)
 );
 
 #endif /* _TRACE_ZSMALLOC_H */
diff --git a/mm/zsmalloc.c b/mm/zsmalloc.c
index e425de4..c7f79d5 100644
--- a/mm/zsmalloc.c
+++ b/mm/zsmalloc.c
@@ -2323,7 +2323,7 @@ unsigned long zs_compact(struct zs_pool *pool)
 	struct size_class *class;
 	unsigned long pages_compacted_before = pool->stats.pages_compacted;
 
-	trace_zsmalloc_compact_start(pool->name);
+	trace_zs_compact_start(pool->name);
 
 	for (i = zs_size_classes - 1; i >= 0; i--) {
 		class = pool->size_class[i];
@@ -2334,9 +2334,8 @@ unsigned long zs_compact(struct zs_pool *pool)
 		__zs_compact(pool, class);
 	}
 
-	trace_zsmalloc_compact_end(pool->name,
-		pool->stats.pages_compacted - pages_compacted_before,
-		pool->stats.pages_compacted);
+	trace_zs_compact_end(pool->name,
+		pool->stats.pages_compacted - pages_compacted_before);
 
 	return pool->stats.pages_compacted;
 }
-- 
1.9.1

Back to linux.kernel | Previous | NextNext in thread | Find similar | Unroll thread


Thread

[PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
  [PATCH v2 4/8] mm/zsmalloc: use class->objs_per_zspage to get num of max objects Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
  [PATCH v2 6/8] mm/zsmalloc: keep comments consistent with code Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
    Re: [PATCH v2 6/8] mm/zsmalloc: keep comments consistent with code Minchan Kim <minchan@kernel.org> - 2016-07-06 04:50 +0200
  [PATCH v2 5/8] mm/zsmalloc: avoid calculate max objects of zspage twice Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
    Re: [PATCH v2 5/8] mm/zsmalloc: avoid calculate max objects of  zspage twice Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2016-07-05 03:20 +0200
    Re: [PATCH v2 5/8] mm/zsmalloc: avoid calculate max objects of  zspage twice Minchan Kim <minchan@kernel.org> - 2016-07-06 04:50 +0200
  [PATCH v2 8/8] mm/zsmalloc: use helper to clear page->flags bit Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
    Re: [PATCH v2 8/8] mm/zsmalloc: use helper to clear page->flags bit Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2016-07-04 10:50 +0200
  [PATCH v2 2/8] mm/zsmalloc: use obj_index to keep consistent with others Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
    Re: [PATCH v2 2/8] mm/zsmalloc: use obj_index to keep consistent  with others Minchan Kim <minchan@kernel.org> - 2016-07-06 04:40 +0200
  [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 09:00 +0200
    Re: [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2016-07-04 10:50 +0200
      Re: [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-04 11:30 +0200
        Re: [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Sergey Senozhatsky <sergey.senozhatsky.work@gmail.com> - 2016-07-05 03:10 +0200
          Re: [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Minchan Kim <minchan@kernel.org> - 2016-07-06 04:50 +0200
            Re: [PATCH v2 7/8] mm/zsmalloc: add __init,__exit attribute Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-06 08:30 +0200
  Re: [PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface Steven Rostedt <rostedt@goodmis.org> - 2016-07-05 19:00 +0200
  Re: [PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface Minchan Kim <minchan@kernel.org> - 2016-07-06 04:40 +0200
    Re: [PATCH v2 1/8] mm/zsmalloc: modify zs compact trace interface Ganesh Mahendran <opensource.ganesh@gmail.com> - 2016-07-06 08:30 +0200

csiph-web