Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1417921
| From | Michael Neuling <mikey@neuling.org> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction |
| Date | 2016-06-09 00:30 +0200 |
| Message-ID | <rHU93-66b-3@gated-at.bofh.it> (permalink) |
| References | <rFA4N-5VV-7@gated-at.bofh.it> <rFAet-5Zh-9@gated-at.bofh.it> <rGOIq-4dq-37@gated-at.bofh.it> <rHP9n-2X5-9@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Wed, 2016-06-08 at 22:31 +0530, Shreyas B Prabhu wrote: > Hi Ben, > > Sorry for the delayed response. > > On 06/06/2016 03:58 AM, Benjamin Herrenschmidt wrote: > > > > On Thu, 2016-06-02 at 07:38 -0500, Shreyas B. Prabhu wrote: > > > > > > @@ -61,8 +72,13 @@ save_sprs_to_stack: > > > * Note all register i.e per-core, per-subcore or per-thread > > > is saved > > > * here since any thread in the core might wake up first > > > */ > > > +BEGIN_FTR_SECTION > > > + mfspr r3,SPRN_PTCR > > > + std r3,_PTCR(r1) > > > +FTR_SECTION_ELSE > > > mfspr r3,SPRN_SDR1 > > > std r3,_SDR1(r1) > > > +ALT_FTR_SECTION_END_IFSET(CPU_FTR_ARCH_300) > > This is the only new SPR we care about in P9 ? > > > After reviewing ISA again, I've identified LMRR, LMSER and ASDR also > need to be restored. I've fixed this in v6. LMRR and LMSER are used the load monitored patch set. There they will get restored when we context switch back to userspace. It probably doesn't hurt that much but you don't need to restore them here. They are not used in the kernel. It escapes me what ASDR is right now. Mikey
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v5 00/11] powerpc/powernv/cpuidle: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 09/11] cpuidle/powernv: Use CPUIDLE_STATE_MAX instead of MAX_POWERNV_IDLE_STATES "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 11/11] powerpc/powernv: Use deepest stop state when cpu is offlined "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 02/11] powerpc/kvm: make hypervisor state restore a function "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 10/11] cpuidle/powernv: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 06/11] powerpc/powernv: abstraction for saving SPRs before entering deep idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 05/11] powerpc/powernv: Make pnv_powersave_common more generic "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 03/11] powerpc/powernv: Rename idle_power7.S to idle_power_common.S "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
[PATCH v5 07/11] powerpc/powernv: set power_save func after the idle states are initialized "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
[PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Benjamin Herrenschmidt <benh@au1.ibm.com> - 2016-06-06 00:30 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Shreyas B Prabhu <shreyas@linux.vnet.ibm.com> - 2016-06-08 19:10 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Michael Neuling <mikey@neuling.org> - 2016-06-09 00:30 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Sam Bobroff <sam.bobroff@au1.ibm.com> - 2016-06-09 06:50 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Shreyas B Prabhu <shreyas@linux.vnet.ibm.com> - 2016-06-09 18:10 +0200
[PATCH v5 01/11] powerpc/powernv: Use PNV_THREAD_WINKLE macro while requesting for winkle "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
[PATCH v5 04/11] powerpc/powernv: Rename reusable idle functions to hardware agnostic names "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
csiph-web