Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1418459
| From | Shreyas B Prabhu <shreyas@linux.vnet.ibm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction |
| Date | 2016-06-09 18:10 +0200 |
| Message-ID | <rIaGR-ec-13@gated-at.bofh.it> (permalink) |
| References | <rFA4N-5VV-7@gated-at.bofh.it> <rFAet-5Zh-9@gated-at.bofh.it> <rI04N-1sK-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On 06/09/2016 10:12 AM, Sam Bobroff wrote: > On Thu, Jun 02, 2016 at 07:38:58AM -0500, Shreyas B. Prabhu wrote: > > ... > >> +/* Power Management - PSSCR Fields */ > > It might be nice to give the full name of the register, as below with the FPSCR. > I'll make the change while posting the next rev. Thanks, Shreyas >> +#define PSSCR_RL_MASK 0x0000000F >> +#define PSSCR_MTL_MASK 0x000000F0 >> +#define PSSCR_TR_MASK 0x00000300 >> +#define PSSCR_PSLL_MASK 0x000F0000 >> +#define PSSCR_EC 0x00100000 >> +#define PSSCR_ESL 0x00200000 >> +#define PSSCR_SD 0x00400000 >> + >> + >> /* Floating Point Status and Control Register (FPSCR) Fields */ > > Cheers, > Sam. >
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v5 00/11] powerpc/powernv/cpuidle: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 09/11] cpuidle/powernv: Use CPUIDLE_STATE_MAX instead of MAX_POWERNV_IDLE_STATES "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 11/11] powerpc/powernv: Use deepest stop state when cpu is offlined "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 02/11] powerpc/kvm: make hypervisor state restore a function "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 10/11] cpuidle/powernv: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 06/11] powerpc/powernv: abstraction for saving SPRs before entering deep idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 05/11] powerpc/powernv: Make pnv_powersave_common more generic "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 03/11] powerpc/powernv: Rename idle_power7.S to idle_power_common.S "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
[PATCH v5 07/11] powerpc/powernv: set power_save func after the idle states are initialized "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
[PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Benjamin Herrenschmidt <benh@au1.ibm.com> - 2016-06-06 00:30 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Shreyas B Prabhu <shreyas@linux.vnet.ibm.com> - 2016-06-08 19:10 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Michael Neuling <mikey@neuling.org> - 2016-06-09 00:30 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Sam Bobroff <sam.bobroff@au1.ibm.com> - 2016-06-09 06:50 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Shreyas B Prabhu <shreyas@linux.vnet.ibm.com> - 2016-06-09 18:10 +0200
[PATCH v5 01/11] powerpc/powernv: Use PNV_THREAD_WINKLE macro while requesting for winkle "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
[PATCH v5 04/11] powerpc/powernv: Rename reusable idle functions to hardware agnostic names "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
csiph-web