Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1412201
| From | "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | [PATCH v5 07/11] powerpc/powernv: set power_save func after the idle states are initialized |
| Date | 2016-06-02 14:50 +0200 |
| Message-ID | <rFAeu-5Zh-15@gated-at.bofh.it> (permalink) |
| References | <rFA4N-5VV-7@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
pnv_init_idle_states discovers supported idle states from the
device tree and does the required initialization. Set power_save
function pointer only after this initialization is done
Reviewed-by: Gautham R. Shenoy <ego@linux.vnet.ibm.com>
Signed-off-by: Shreyas B. Prabhu <shreyas@linux.vnet.ibm.com>
---
- No changes since v1
arch/powerpc/platforms/powernv/idle.c | 3 +++
arch/powerpc/platforms/powernv/setup.c | 2 +-
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/arch/powerpc/platforms/powernv/idle.c b/arch/powerpc/platforms/powernv/idle.c
index fcc8b68..fbb09fb 100644
--- a/arch/powerpc/platforms/powernv/idle.c
+++ b/arch/powerpc/platforms/powernv/idle.c
@@ -285,6 +285,9 @@ static int __init pnv_init_idle_states(void)
}
pnv_alloc_idle_core_states();
+
+ if (supported_cpuidle_states & OPAL_PM_NAP_ENABLED)
+ ppc_md.power_save = power7_idle;
out_free:
kfree(flags);
out:
diff --git a/arch/powerpc/platforms/powernv/setup.c b/arch/powerpc/platforms/powernv/setup.c
index ee6430b..8492bbb 100644
--- a/arch/powerpc/platforms/powernv/setup.c
+++ b/arch/powerpc/platforms/powernv/setup.c
@@ -315,7 +315,7 @@ define_machine(powernv) {
.get_proc_freq = pnv_get_proc_freq,
.progress = pnv_progress,
.machine_shutdown = pnv_shutdown,
- .power_save = power7_idle,
+ .power_save = NULL,
.calibrate_decr = generic_calibrate_decr,
#ifdef CONFIG_KEXEC
.kexec_cpu_down = pnv_kexec_cpu_down,
--
2.1.4
Back to linux.kernel | Previous | Next — Previous in thread | Next in thread | Find similar | Unroll thread
[PATCH v5 00/11] powerpc/powernv/cpuidle: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 09/11] cpuidle/powernv: Use CPUIDLE_STATE_MAX instead of MAX_POWERNV_IDLE_STATES "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 11/11] powerpc/powernv: Use deepest stop state when cpu is offlined "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 02/11] powerpc/kvm: make hypervisor state restore a function "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 10/11] cpuidle/powernv: Add support for POWER ISA v3 idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 06/11] powerpc/powernv: abstraction for saving SPRs before entering deep idle states "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 05/11] powerpc/powernv: Make pnv_powersave_common more generic "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:40 +0200
[PATCH v5 03/11] powerpc/powernv: Rename idle_power7.S to idle_power_common.S "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
[PATCH v5 07/11] powerpc/powernv: set power_save func after the idle states are initialized "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
[PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Benjamin Herrenschmidt <benh@au1.ibm.com> - 2016-06-06 00:30 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Shreyas B Prabhu <shreyas@linux.vnet.ibm.com> - 2016-06-08 19:10 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Michael Neuling <mikey@neuling.org> - 2016-06-09 00:30 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Sam Bobroff <sam.bobroff@au1.ibm.com> - 2016-06-09 06:50 +0200
Re: [PATCH v5 08/11] powerpc/powernv: Add platform support for stop instruction Shreyas B Prabhu <shreyas@linux.vnet.ibm.com> - 2016-06-09 18:10 +0200
[PATCH v5 01/11] powerpc/powernv: Use PNV_THREAD_WINKLE macro while requesting for winkle "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
[PATCH v5 04/11] powerpc/powernv: Rename reusable idle functions to hardware agnostic names "Shreyas B. Prabhu" <shreyas@linux.vnet.ibm.com> - 2016-06-02 14:50 +0200
csiph-web