Groups | Search | Server Info | Keyboard shortcuts | Login | Register [http] [https] [nntp] [nntps]
Groups > linux.kernel > #1245665
| From | Arnd Bergmann <arnd@arndb.de> |
|---|---|
| Newsgroups | linux.kernel |
| Subject | Re: [PATCH v3 11/13] Documentation: devicetree: ufs: Add DT bindings for exynos UFS host controller |
| Date | 2015-10-13 14:20 +0200 |
| Message-ID | <qj6IF-6iL-7@gated-at.bofh.it> (permalink) |
| References | <qeHfQ-6EV-7@gated-at.bofh.it> <qeKnp-2Lo-37@gated-at.bofh.it> <qj6fD-5t6-5@gated-at.bofh.it> |
| Organization | linux.* mail to news gateway |
On Tuesday 13 October 2015 17:06:18 Alim Akhtar wrote: > > Better rename them to "core", "ref" and "iface", no point requiring to > > spell out "clk" here. > > > >> + ufs,pwr-attr-mode = "FAST"; > > > > A string is rather unusual here, what are the allowed values? Could you > > use a boolean property instead? > > > will update the binding, supported modes are FAST, SLOW, FAST_auto etc, > so kept the string for more readability > > >> + ufs,pwr-attr-lane = /bits/ 8 <2>; > >> + ufs,pwr-attr-gear = /bits/ 8 <2>; > > > > Why the "/bits/ 8" ? > > > I am using of_property_read_u8() to read 8 bit value from property. > I still think it would be better to stay with conventional methods here, and change the code accordingly. You can easily use of_property_read_u32 for the last two properties. Arnd -- To unsubscribe from this list: send the line "unsubscribe linux-kernel" in the body of a message to majordomo@vger.kernel.org More majordomo info at http://vger.kernel.org/majordomo-info.html Please read the FAQ at http://www.tux.org/lkml/
Back to linux.kernel | Previous | Next — Previous in thread | Find similar | Unroll thread
Re: [PATCH v3 11/13] Documentation: devicetree: ufs: Add DT bindings for exynos UFS host controller Alim Akhtar <alim.akhtar@samsung.com> - 2015-10-13 13:50 +0200 Re: [PATCH v3 11/13] Documentation: devicetree: ufs: Add DT bindings for exynos UFS host controller Arnd Bergmann <arnd@arndb.de> - 2015-10-13 14:20 +0200
csiph-web